PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Connexion à un serveur IMAP en utilisant une variable de type emailSessionIMAP
  • Connexion à un serveur SMTP Sécurisé
EmailOuvreSession (Exemple)
Connexion à un serveur IMAP en utilisant une variable de type emailSessionIMAP
// Le compte IMAP est défini chez Gmail
gSessionIMAP est une emailSessionIMAP
gSessionIMAP..AdresseServeur = "imap.gmail.com"
gSessionIMAP..Nom = "utilisateur@gmail.com"
gSessionIMAP..MotDePasse = "secret"
gSessionIMAP..Port = 993
gSessionIMAP..Option = optionSSL
 
// Ouverture de la session Gmail
SI EmailOuvreSession(gSessionIMAP) = Faux ALORS
// Echec de l'ouverture
ErreurInfo(errComplet)
FIN
 
Connexion à un serveur SMTP Sécurisé
// Il s'agit dans cet exemple d'un serveur Gmail
 
// Session SMTP sécurisée
gSessionSMTP est une emailSessionSMTP
gSessionSMTP..AdresseServeur = "smtp.gmail.com"
gSessionSMTP..Nom = "utilisateur@gmail.com"
gSessionSMTP..MotDePasse = "secret"
gSessionSMTP..Port = 587
gSessionSMTP..Option = emailOptionSécuriséTLS
 
// Ouverture de la session
SI EmailOuvreSession(gSessionSMTP) = Faux ALORS
Erreur(ErreurInfo(errComplet))
FIN
 
Version minimum requise
  • Version 15
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire