PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Exemple 1 : Suppression du cinquième email reçu par le protocole POP3
  • Exemple 2 : Suppression d'emails reçus par l'intermédiaire de MS Exchange
EmailSupprimeMessage (Exemple)
Exemple 1 : Suppression du cinquième email reçu par le protocole POP3
Le code suivant permet de lire le cinquième email reçu et de le supprimer. Les caractéristiques du protocole POP3 ont été précisées grâce à la fonction EmailOuvreSession (adresse du serveur POP3, adresse du serveur SMTP, etc.).
// Ouverture de la session d'email
SI EmailOuvreSession(USER, PASSWORD, "pop3.gmail.com", "smtp.gmail.com") = Vrai ALORS
NomUser = USER
SINON
NomUser = ""
Erreur("Impossible d'établir la connexion")
FIN
// Lecture des messages reçus
I est un entier
nbMSG est un entier = EmailNbMessage(NomUser)
POUR I = 1 À nbMSG
EmailLitMessage(NomUser, I)
SI I = 5 ALORS
EmailSupprimeMessage(NomUser, 5)
FIN
FIN
Exemple 2 : Suppression d'emails reçus par l'intermédiaire de MS Exchange
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindowsCode Utilisateur (MCU)Ajax Le code suivant permet de supprimer des emails reçus dans MS Exchange. Ces emails sont présents dans la boîte de réception de MS Exchange et sur le serveur. Un profil "PROFIL_Exemple" a été créé sous MS Exchange. Pour plus de détails sur la création des profils, consultez la fonction EmailOuvreSession.
IDEmail est un entier
// Ouverture de la session d'email
IDEmail = EmailOuvreSession("PROFIL_Exemple")
// Lit tous les messages reçus et demande la suppression de certains messages
EmailLitPremier(IDEmail)
TANTQUE Email.EnDehors = Faux
SI OuiNon(Email.Sujet + RC + "Voulez vous supprimer ce message?") ALORS
EmailSupprimeMessage(IDEmail)
FIN
EmailLitSuivant(IDEmail)
FIN
...
EmailFermeSession(IDEmail)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire