PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Gestion de l'erreur lors de l'envoi d'un email par le protocole POP3
EmailMsgErreur (Exemple)
Gestion de l'erreur lors de l'envoi d'un email par le protocole POP3
Le code suivant permet d'envoyer un email en utilisant le protocole POP3. Les caractéristiques du protocole POP3 ont été précisées grâce à la fonction EmailOuvreSession (adresse du serveur POP3, adresse du serveur SMTP, etc.).
En cas d'erreur, le message complet de l'erreur est affiché. Lorsque l'email est envoyé, la session est fermée.
// Ouverture de la session d'email
SI EmailOuvreSession(USER, PASSWORD, "pop3.ifrance.fr", "smtp.ifrance.fr") = Vrai ALORS
          NomUser = USER
SINON
          NomUser = ""
          Erreur("Impossible d'établir la connexion")
FIN
// Initialise les composantes de l'email
Email.Expéditeur = "<user@pcsoft.fr>"    // L'expéditeur
Email.Destinataire[1] = DESTINATAIRE     // Le destinataire
Email.NbDestinataire = 1     // Le nombre de destinataires
Email.Sujet = SUJET          // Le sujet
Email.Message = TEXTE        // Le corps du message
Email.NbAttache = 0          // Le nombre de pièces attachées
// Envoie de l'email
SI EmailEnvoieMessage(NomUser) = Faux ALORS
          Erreur(EmailMsgErreur(Email.Erreur))
FIN
...
EmailFermeSession(NomUser)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire