PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Sauvegarde du fichier attaché sélectionné
  • Sauvegarde du fichier attaché sélectionné
EmailSauveFichierAttaché (Exemple)
Sauvegarde du fichier attaché sélectionné
WINDEVEtats et RequêtesJavaCode Utilisateur (MCU) Le code suivant permet de sauvegarder sur le poste local le fichier attaché sélectionné dans un champ Liste.
// -- Initialisation du champ Liste LISTE_Attache
I est un entier = 0
POUR I = 1 À Email.NbAttache
ListeAjoute(LISTE_Attache, Email.Attache[I])
FIN
// -- Clic du champ Bouton BTN_COPIER
// Copie du fichier attaché sélectionné
Select est un entier = ListeSelect(LISTE_Attache)
SI Select <= 0 ALORS
Info("Il faut sélectionner un fichier attaché")
SINON
NomFichier est une chaîne
NomFichier = fSélecteur("", "", "Sauvegarde du fichier attaché", ...
"*.*", "", fselCrée)
EmailSauveFichierAttaché(LISTE_Attache[Select], NomFichier)
FIN
Sauvegarde du fichier attaché sélectionné
WEBDEV - Code ServeurAjax Le code suivant permet de sauvegarder sur le poste local (le serveur) le fichier attaché sélectionné dans un champ Liste.
// -- Initialisation du champ Liste LISTE_Attache
I est un entier = 0
POUR I = 1 À Email.NbAttache
ListeAjoute(LISTE_Attache, Email.Attache[I])
FIN
// -- Clic du champ Bouton BTN_COPIER
// Copie du fichier attaché sélectionné
Select est un entier = ListeSelect(LISTE_Attache)
SI Select <= 0 ALORS
Info("Il faut sélectionner un fichier attaché")
SINON
NomFichier est une chaîne
NomFichier = fRepEnCours() + "\Emails\"
EmailSauveFichierAttaché(LISTE_Attache[Select], ...
NomFichier + LISTE_Attache[Select])
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire