PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Lecture des emails reçus dans la boîte aux lettres POP3
EmailLitMessage (Exemple)
Lecture des emails reçus dans la boîte aux lettres POP3
Le code suivant permet de lire tous les emails présents dans la boîte aux lettres POP3.
// Ouverture de la session POP3
SI EmailOuvreSession(USER, PASSWORD, "pop3.ifrance.fr", ...
"smtp.ifrance.fr") = Vrai ALORS
  NomUser = USER
SINON
  NomUser = ""
  Erreur("Impossible d'établir la connexion")
FIN
 
...
 
I est un entier
// Récupération du nombre de messages dans la boîte aux lettres POP3
nbMSG est un entier = EmailNbMessage(NomUser)
// Parcourt les messages et récupère la structure email dans un fichier HFSQL
POUR I = 1 À nbMSG
EmailLitMessage(NomUser,I)
// Teste l'existence du message
SI Email.EnDehors <> Vrai ALORS
// Les variables de la structure email sont transférées
      // dans les rubriques du fichier
      ME.NOM = Email.Expéditeur
      ME.MESSAGE = Email.Message
      ...
      HAjoute(Message)
  SINON
      // Le message n'existe plus
      Info("Ce message a été supprimé")
  FIN
FIN
 
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire