PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple 1 : Lecture du premier email reçu par le protocole POP3
  • Exemple 2 : Lecture du premier email reçu par l'intermédiaire de MS Exchange
  • Exemple 3 : Lecture du premier email reçu par l'intermédiaire de Pocket Outlook
EmailLitPremier (Exemple)
Exemple 1 : Lecture du premier email reçu par le protocole POP3
Le code suivant permet de lire les emails reçus présents dans la boîte aux lettres du protocole POP3. Ces emails sont lus du premier au dernier et sont affichés dans la table "TABLE_Table_Email". Les caractéristiques du protocole POP3 ont été précisées grâce à la fonction EmailOuvreSession (adresse du serveur POP3, adresse du serveur SMTP, etc.).
// Ouverture de la session d'email
SI EmailOuvreSession(USER, PASSWORD, "pop3.ifrance.fr", ...
"smtp.ifrance.fr") = Vrai ALORS
NomUser = USER
SINON
NomUser = ""
Erreur("Impossible d'établir la connexion")
FIN
 
// Remplissage d'un table avec les messages reçus
EmailLitPremier(NomUser)
TANTQUE Email.EnDehors = Faux
TableAjoute(TABLE_Table_Email, Email.Expéditeur + TAB + Email.Sujet)
EmailLitSuivant(NomUser)
FIN
Exemple 2 : Lecture du premier email reçu par l'intermédiaire de MS Exchange
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindowsAjaxCode Utilisateur (MCU) Le code suivant utilise MS Exchange pour lire les nouveaux emails reçus. Ces emails sont présents dans la boîte de réception de MS Exchange. Un profil "PROFIL_Exemple" a été créé sous MS Exchange. Pour plus de détails sur la création des profils, consultez la fonction EmailOuvreSession.
IDEmail est un entier
// Ouverture de la session d'email
IDEmail = EmailOuvreSession("PROFIL_Exemple")
// Récupération des messages
// dans la boîte de réception de MS Exchange
EmailMiseAJour(IDEmail)
// Parcours des nouveaux messages reçus
// depuis le premier jusqu'au dernier
EmailLitPremier(IDEmail, "NON LUS")
TANTQUE Email.EnDehors = Faux
SI OuiNon("Vous avez reçu un email de " + Email.Expéditeur + ...
"Voulez-vous le lire ?") ALORS
// Ouverture de la fenêtre de lecture des messages
Ouvre(FEN_Email_RCV)
SINON
EmailLitSuivant(IDEmail, "NON LUS")
FIN
FIN
...
EmailFermeSession(IDEmail)
Exemple 3 : Lecture du premier email reçu par l'intermédiaire de Pocket Outlook
Windows Mobile Le code suivant utilise Pocket Outlook pour lire les nouveaux emails reçus. Ces emails sont présents dans la boîte de réception de Pocket Outlook. Un compte "Compte_Exemple" a été créé sous Pocket Outlook. Pour plus de détails sur la création des comptes, consultez Gérez les emails grâce à CEMAPI : Autres comptes.
IDEmail est un entier
// Ouverture de la session d'email
IDEmail = EmailOuvreSession("Compte_Exemple")
// Parcours des nouveaux messages reçus
// depuis le premier jusqu'au dernier
EmailLitPremier(IDEmail, "NON LUS")
TANTQUE Email.EnDehors = Faux
SI OuiNon("Vous avez reçu un email de " + Email.Expéditeur + ...
"Voulez-vous le lire ?") ALORS
// Ouverture de la fenêtre de lecture des messages
Ouvre(FEN_Email_RCV)
SINON
EmailLitSuivant(IDEmail, "NON LUS")
FIN
FIN
...
EmailFermeSession(IDEmail)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire