PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Lecture de l'email précédent reçu dans la boîte aux lettres POP3
EmailLitPrécédent (Exemple)
Lecture de l'email précédent reçu dans la boîte aux lettres POP3
Le code suivant permet de lire tous les emails reçus, du plus récent au plus ancien. Pour chaque email, l'utilisateur peut visualiser l'ensemble de l'email dans la fenêtre "FEN_Email_RCV".
// Ouverture de la session d'emails (protocole POP3)
SI EmailOuvreSession(USER, PASSWORD, "pop3.ifrance.fr", ...
"smtp.ifrance.fr") = Vrai ALORS
NomUser = USER
SINON
NomUser = ""
Erreur("Impossible d'établir la connexion")
FIN
 
...
 
// Lecture du dernier enregistrement reçu
EmailLitDernier(NomUser)
// Parcours des emails (du plus récent au plus ancien)
TANTQUE Email.EnDehors = Faux
SI Confirmer("Message de" + Email.Expéditeur + ...
"Voulez vous lire ce message ?") ALORS
Ouvre(FEN_Email_RCV)
SINON
EmailLitPrécédent(NomUser)
FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire