PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Exemple : Fermer une session d'emails utilisant le protocole POP3/SMTP
  • Exemple : Fermer une session d'emails utilisant MS Exchange
EmailFermeSession (Exemple)
Exemple : Fermer une session d'emails utilisant le protocole POP3/SMTP
Le code suivant permet d'envoyer un email en utilisant le protocole SMTP. Les caractéristiques du protocole POP3/SMTP ont été précisées grâce à la fonction EmailOuvreSession (adresse du serveur POP3, adresse du serveur SMTP, etc.).
Lorsque l'email est envoyé, la session est fermée.
SI EmailOuvreSession(USER, PASSWORD, "pop3.serveur.com", ...
"smtp.serveur.com") = Vrai ALORS
  NomUser = USER
SINON
  NomUser = ""
  Erreur("Impossible d'établir la connexion")
FIN
 
// Initialise les composantes du mail
Email.Expéditeur = "<user@pcsoft.fr>"    // L'expéditeur
Email.Destinataire[1] = DESTINATAIRE     // Le destinataire
Email.NbDestinataire = 1     // Le nombre de destinataires
Email.Sujet = SUJET          // Le sujet
Email.Message = TEXTE        // Le corps du message
Email.NbAttache = 0          // Le nombre de pièces attachées
 
// Envoie le mail
SI EmailEnvoieMessage(NomUser) = Faux ALORS
  Erreur()
FIN
...
EmailFermeSession(NomUser)
Exemple : Fermer une session d'emails utilisant MS Exchange
WINDEVWEBDEV - Code ServeurEtats et RequêtesCode Utilisateur (MCU)Ajax Le code suivant utilise MS Exchange pour envoyer un email. Un profil "PROFIL_Exemple" a été créé sous MS Exchange. Pour plus de détails sur la création des profils, consultez la fonction EmailOuvreSession.
Lorsque l'email est envoyé, la session est fermée.
IDEmail est un entier
IDEmail = EmailOuvreSession("PROFIL_Exemple")
// Initialisation des variables
Email.NbDestinataire = 1
Email.Destinataire[1] = "pcsoft@pcsoft.fr"
Email.NbAttache = 0
Email.Message = ""
// Envoie du message à MS Exchange
EmailEnvoieMessage(IDEmail)
...
EmailMiseAJour(IDEmail)
...
EmailFermeSession(IDEmail)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire