PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Exemple : Envoi d'un email entièrement paramétré
EmailEnvoie (Exemple)
Exemple : Envoi d'un email entièrement paramétré
Le code suivant permet d'envoyer un email dont le contenu est entièrement personnalisé. Les variables email permettent de saisir les principales caractéristiques de l'email.
Lorsque l'email est envoyé, la session est fermée.
// Création du message
ContenuMessage est une chaîne
ContenuMessage = "Return-Path: <%1>" + RC + ...
"From: ""%2"" <%1>" + RC + ...
"To: <%3>" + RC + ...
"Subject: %4" + RC + ...
"MIME-Version: 1.0" + RC + ...
"Content-Type: text/plain;" + RC + ...
"Charset=""us-ascii""" + RC + ...
"Content-Transfer-Encoding: 7bit" + RC + RC + "%5" + RC
 
// Ouverture d'une session SMTP
EmailOuvreSessionSMTP("SessionSMTP", "HL")
SI ErreurDétectée = Vrai ALORS
Erreur(ErreurInfo(errRésumé))
RETOUR
FIN
 
// Remise a zéro des variables Email
EmailRAZ()
 
// Expéditeur du message
Email.Expéditeur = "expediteur@expediteur.fr"
Email.AdresseExpéditeur = "M. Expéditeur"
 
// Destinataire(s) du message
Email.NbDestinataire = 1
Email.Destinataire[1] = "destinataire@destinataire.fr"
 
// Sujet et contenu du message
Email.Sujet = "Sujet email"
Email.Message = "Corps de l'email"
SI fSauveTexte("ContenuEmail.txt", ...
ChaîneConstruit(ContenuMessage, Email.Expéditeur, Email.AdresseExpéditeur, ...
Email.Destinataire[1], Email.Sujet,Email.Message)) = Faux ALORS
Erreur(ErreurInfo())
SINON
EmailEnvoie("SessionSMTP", "ContenuEmail.txt")
SI ErreurDétectée = Vrai ALORS
Erreur(ErreurInfo())
FIN
FIN
 
// Fermeture de la session SMTP
EmailFermeSession("SessionSMTP")
fSupprime("ContenuEmail.txt")
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire