PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Tracé de plusieurs dessins ayant une couleur et un style de trait identiques
Tracé de plusieurs dessins ayant une couleur et un style de trait identiques
Le code suivant permet de tracer plusieurs dessins (un cercle et un rectangle) ayant une couleur et un style du trait identiques. Les dessins seront tracés dans un champ Image (IMG_ImageDessin). La couleur et le style du trait sont sélectionnés par l'utilisateur à l'aide de deux sélecteurs (SEL_SelecteurCouleur et SEL_SelecteurStyle).
// Déclaration des variables
CouleurTrait est un entier
StyleTrait est un entier
 
// Récupération de la couleur du trait sélectionnée
SELON SEL_SelecteurCouleur
CAS 1 : CouleurTrait = RougeClair
CAS 2 : CouleurTrait = BleuClair
CAS 3 : CouleurTrait = VertClair
CAS 4 : CouleurTrait = JauneClair
FIN
// Récupération du type du trait sélectionnée
SELON SEL_SelecteurStyle
CAS 1 : StyleTrait = 0
CAS 2 : StyleTrait = 1
CAS 3 : StyleTrait = 2
CAS 4 : StyleTrait = 3
CAS 5 : StyleTrait = 4
CAS 6 : StyleTrait = 5
FIN
 
// Initialisation de la couleur et du style des traits
dStylo(IMG_ImageDessin, CouleurTrait, StyleTrait)
// Tracé du cercle
dCercle(IMG_ImageDessin, 10, 10, 50, 50)
// Tracé du rectangle
dRectangle(IMG_ImageDessin, 40, 40, 80, 80)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire