PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Tracé d'un rectangle dans un champ Image
dRectangle (Exemple)
Tracé d'un rectangle dans un champ Image
Le code suivant permet de tracer un rectangle dans un champ Image (IMG_ImageDessin). Les coordonnées du rectangle sont saisies par l'utilisateur dans des champs de saisie (SAI_X1, SAI_Y1, SAI_X2, SAI_Y2). La couleur de fond du rectangle et la couleur du trait du rectangle sont sélectionnées par l'utilisateur à l'aide de deux sélecteurs (SEL_SelectFond et SEL_SelectTrait).
// Déclaration des variables
CouleurFond est un entier
CouleurTrait est un entier
 
// Déclaration du dessin dans le champ Image "IMG_ImageDessin"
dDébutDessin(IMG_ImageDessin)
 
// Récupération de la couleur de fond sélectionnée
SELON SEL_SelectFond
CAS 1 : CouleurFond = RougeClair
CAS 2 : CouleurFond = BleuClair
CAS 3 : CouleurFond = VertClair
CAS 4 : CouleurFond = JauneClair
FIN
 
// Récupération de la couleur du trait sélectionnée
SELON SEL_SelectTrait
CAS 1 : CouleurTrait = RougeClair
CAS 2 : CouleurTrait = BleuClair
CAS 3 : CouleurTrait = VertClair
CAS 4 : CouleurTrait = JauneClair
FIN
 
// Tracé du rectangle
dRectangle(SAI_X1, SAI_Y1, SAI_X2, SAI_Y2, CouleurFond, CouleurTrait)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire