DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


RVB
TSL
  • Tracé d'une portion de cercle dans un champ Image
Tracé d'une portion de cercle dans un champ Image
Le code suivant permet de tracer une portion de cercle dans un champ Image (IMG_ImageDessin). Les coordonnées du rectangle dans lequel le cercle sera inscrit et les coordonnées du point de départ et du point d'arrivée de la portion de cercle sont saisies par l'utilisateur dans des champs de saisie (EDT_X1, EDT_Y1, EDT_X2, EDT_Y2, EDT_X3, EDT_Y3, EDT_X4, EDT_Y4). La couleur du fond et la couleur du trait de la portion de cercle sont sélectionnées par l'utilisateur à l'aide de deux sélecteurs (SEL_SelectFond et SEL_SelectTrait).
// Déclaration des variables
CouleurFond est un entier
CouleurTrait est un entier
 
// Le dessin va être dessiné dans le champ Image "IMG_ImageDessin"
dDébutDessin(IMG_ImageDessin)
 
// Récupération de la couleur de fond sélectionnée
SELON SEL_SelectFond
CAS 1 : CouleurFond = RougeClair
CAS 2 : CouleurFond = BleuClair
CAS 3 : CouleurFond = VertClair
CAS 4 : CouleurFond = JauneClair
FIN
 
// Récupération de la couleur du trait sélectionnée
SELON SEL_SelectTrait
CAS 1 : CouleurTrait = RougeClair
CAS 2 : CouleurTrait = BleuClair
CAS 3 : CouleurTrait = VertClair
CAS 4 : CouleurTrait = JauneClair
FIN
 
// Tracé de la portion de cercle
dPortion(EDT_X1, EDT_Y1, EDT_X2, EDT_Y2, EDT_X3, EDT_Y3, EDT_X4, EDT_Y4, CouleurFond, CouleurTrait)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire