PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Dessin d'un cercle point par point
Dessin d'un cercle point par point
Le code suivant permet de dessiner un cercle composé de plusieurs points dans un champ Image (IMG_ImageDessin). Les coordonnées du centre du cercle et le rayon sont saisies par l'utilisateur dans des champs de saisie (SAI_PosCentreH, SAI_PosCentreV et SAI_Rayon). La couleur du point central et la couleur du cercle sont sélectionnées par l'utilisateur à l'aide de deux sélecteurs (SEL_SelectCouleurPoint et SEL_SelectCouleurCercle).
// Déclaration des variables
CouleurPoint est un entier
CouleurCercle est un entier
Indice est un entier
X, Y sont des entiers

// Déclaration du dessin dans le champ Image "IMG_ImageDessin"
dDébutDessin(IMG_ImageDessin)

// Récupération de la couleur du point central sélectionnée
SELON SEL_SelectCouleurPoint
        CAS 1 : CouleurPoint = RougeClair
        CAS 2 : CouleurPoint = BleuClair
        CAS 3 : CouleurPoint = VertClair
        CAS 4 : CouleurPoint = JauneClair
FIN

// Récupération de la couleur du cercle sélectionnée
SELON SEL_SelectCouleurCercle
        CAS 1 : CouleurCercle = RougeClair
        CAS 2 : CouleurCercle = BleuClair
        CAS 3 : CouleurCercle = VertClair
        CAS 4 : CouleurCercle = JauneClair
FIN

// Dessin du cercle
POUR Indice = 0 A 360
         X = SAI_PosCentreH + SAI_Rayon * Cosinus(Indice)
         Y = SAI_PosCentreV + SAI_Rayon * Sinus(Indice)
         dPoint(X, Y, CouleurCercle)
FIN

// Dessin du point central
dPoint(SAI_PosCentreH, SAI_PosCentreV, CouleurPoint)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire