PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple 1 : Copie d'une image
  • Exemple 2 : Zoom d'une image
dCopieImage (Exemple)
Exemple 1 : Copie d'une image
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindowsCode Utilisateur (MCU)PHPAjax
Le code suivant permet de copier le contenu d'un champ Image (IMG_ImageSource) dans un second champ Image (IMG_ImageDestination). L'utilisateur sélectionne le mode de copie grâce à un champ Liste (LISTE_ListeMode).
// Déclaration des variables
ResCopie est un booléen
ModeCopie est un entier

// Récupération du mode de copie
SELON LISTE_ListeMode
CAS 1 : ModeCopie = copieToutNoir
CAS 2 : ModeCopie = copieDstInverse
CAS 3 : ModeCopie = copieFusionCopie
CAS 4 : ModeCopie = copiePasSrcCopie
CAS 5 : ModeCopie = copiePasSrcEfface
CAS 6 : ModeCopie = copieSrcEt
CAS 7 : ModeCopie = copieSrcCopie
CAS 8 : ModeCopie = copieSrcEfface
CAS 9 : ModeCopie = copieSrcInverse
CAS 10 : ModeCopie = copieSrcPeint
CAS 11 : ModeCopie = copieToutBlanc
CAS 12 : ModeCopie = copieFusionPeint
CAS 13 : ModeCopie = copiePatCopie
CAS 14 : ModeCopie = copiePatInverse
CAS 15 : ModeCopie = copiePatPeint
FIN

// Copie du contenu du champ Image
ResCopie = dCopieImage(IMG_ImageSource, IMG_ImageDestination, ModeCopie)

// Erreur ?
SI ResCopie = Vrai ALORS
Info("La copie a été effectuée")
SINON
Erreur("La copie n'a pas été effectuée")
FIN
Exemple 2 : Zoom d'une image
Le code suivant permet de réduire de 50 % une image affichée dans un champ Image (IMG_ImageSource) dont les coordonnées sont (0,0), (150,200). L'image réduite est copiée dans un second champ Image (IMG_ImageDestination).
// Déclaration des variables
ResCopie est un booléen

// Réduction de l'image sélectionnée
ResCopie = dCopieImage(IMG_ImageSource, IMG_ImageDestination,...
        copieSrcCopie, 0, 0, 150, 200, 0, 0, 75, 100)

// Erreur ?
SI ResCopie = Vrai ALORS
        Info("La réduction a été effectuée")
SINON
        Erreur("La réduction n'a pas été effectuée")
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire