PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Tracé d'un polygone dans un champ Image
dPolygone (Exemple)
Tracé d'un polygone dans un champ Image
Le code suivant permet de tracer un polygone de 4 côtés dans un champ Image (IMG_ImageDessin). Les coordonnées des sommets du polygone sont saisies par l'utilisateur dans des champs de saisie (X1, Y1, X2, Y2, X3, Y3, X4, Y4). Les couleurs du fond et des côtés du polygone sont sélectionnées par l'utilisateur à l'aide de deux sélecteurs (SEL_SelectFond et SEL_SelectTrait).
// Déclaration des variables
CouleurFond est un entier
CouleurTrait est un entier
 
// Déclaration du dessin dans le champ Image "IMG_ImageDessin"
dDébutDessin(IMG_ImageDessin)
 
// Récupération de la couleur de fond sélectionnée
SELON SEL_SelectFond
CAS 1 : CouleurFond = RougeClair
CAS 2 : CouleurFond = BleuClair
CAS 3 : CouleurFond = VertClair
CAS 4 : CouleurFond = JauneClair
FIN
 
// Récupération de la couleur du trait sélectionnée
SELON SEL_SelectTrait
CAS 1 : CouleurTrait = RougeClair
CAS 2 : CouleurTrait = BleuClair
CAS 3 : CouleurTrait = VertClair
CAS 4 : CouleurTrait = JauneClair
FIN
 
// Tracé du polygone
dPolygone(4, X1, Y1, X2, Y2, X3, Y3, X4, Y4, CouleurFond, CouleurTrait)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire