PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Tracé d'une ligne dans un champ Image
Tracé d'une ligne dans un champ Image
Le code suivant permet de tracer plusieurs dessins (un cercle et un rectangle) ayant une couleur de fond identique. Les dessins seront tracés dans un champ Image (IMG_ImageDessin). La couleur, le style et le type de hachures par défaut du fond des dessins sont sélectionnés par l'utilisateur à l'aide de trois sélecteurs (SEL_SelectFond, SEL_SelectStyle et SEL_SelectHachures).
WINDEV Mobile Dans cette version, il n'est pas possible de hachurer le fond d'un dessin. La troisième option du sélecteur "SEL_SelectStyle" et le sélecteur "SEL_SelectHachures" ne sont pas disponibles.
// Déclaration des variables
CouleurFond est un entier
StyleFond est un entier
HachureFond est un entier
 
// Déclaration du dessin dans le champ Image "IMG_ImageDessin"
dDébutDessin(IMG_ImageDessin)
 
// Récupération de la couleur de fond sélectionnée
SELON SEL_SelectFond
CAS 1 : CouleurFond = RougeClair
CAS 2 : CouleurFond = BleuClair
CAS 3 : CouleurFond = VertClair
CAS 4 : CouleurFond = JauneClair
FIN
 
// Récupération du style du fond sélectionné
SELON SEL_SelectStyle
CAS 1 : StyleFond = 0
CAS 2 : StyleFond = 1
CAS 3 : StyleFond = 2
FIN
 
// Récupération du type de hachures du fond sélectionné
SELON SEL_SelectHachures
CAS 1 : HachureFond = 0
CAS 2 : HachureFond = 1
CAS 3 : HachureFond = 2
CAS 4 : HachureFond = 3
CAS 5 : HachureFond = 4
CAS 6 : HachureFond = 5
FIN
 
// Initialisation du fond des dessins
dFond(CouleurFond, StyleFond, HachureFond)
 
// Tracé du cercle
dCercle(10, 10, 50, 50)
 
// Tracé du rectangle
dRectangle(40, 40, 80, 80)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire