PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

PV

  • Connexion à un serveur DDE
DDEConnecte (Exemple)
Connexion à un serveur DDE
Cet exemple de code est composé :
  • d'un code client permettant de lancer le serveur DDE, d'envoyer et de récupérer des informations.
  • d'un code serveur correspondant aux différentes procédures du serveur DDE.
// Exemple de client
 
// Connexion
NumConnexion est un entier
DDELance(NomServeur)
NumConnexion = DDEConnecte(NomServeur, "MonSujet")
 
// Préparation à la réception des messages
// Traité dans la procédure MODIF
DDEEvénement("MODIF", DDEAModifier)
// ...
// Exécute une action par le serveur
DDEExécute(NumConnexion, "EXE1")
SI DDERécupère(NumConnexion, "Item1") ALORS
Info("La donnée récupérée est" + DDEChaîne())
FIN
 
//...
 
// Envoie une valeur
DDEEnvoie(NumConnexion, "Item2", Valeur)
 
//...
 
// Déconnexion
DDEDéconnecte(NumConnexion)
 
 
// Exemple de serveur
 
// Préparation à la réception des messages
DDEEvénement("ARépondre", DDEARépondre)
DDEEvénement("ARecevoir", DDEARecevoir)
DDEEvénement("AExécuter", DDEAExécuter)// Dans le serveur
// Procédure AExécuter pour faire exécuter un traitement
SI _DDE.Sujet = "MonSujet" ET _DDE.Chaine = "Excel1" ALORS
 _DDE.Cr = 1
 // Traitement
SINON
 _DDE.Cr = 0
FIN
 
 
// Dans le serveur
// Procédure ARépondre pour récupérer une valeur
SI _DDE.Sujet = "MonSujet" ET _DDE.Item = "Item1" ALORS
_DDE.Cr = 1
_DDE.Chaine = ValeurRetour
SINON
_DDE.Cr = 0
FIN
 
// Procédure ARecevoir pour envoyer une valeur
SI _DDE.Sujet = "MonSujet" ET _DDE.Item = "Item2" ALORS
_DDE.Cr = 1
Info("Valeur reçue" + _DDE.Chaine)
SINON
_DDE.Cr = 0
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire