PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Choix des langues de l'application selon les valeurs lues dans un fichier INI
Exemple : Choix des langues de l'application selon les valeurs lues dans un fichier INI
WINDEVJavaCode Utilisateur (MCU)
L'exemple suivant permet lire dans un fichier "MONAPPLI.INI" la langue dans laquelle l'application doit être exécutée.
Res = INILit("EXEC", "LANGUE", "", "MONAPPLI.INI")
SI Res = "" ALORS Erreur("Erreur dans le fichier MONAPPLI.INI")
SELON Res
CAS "FRANCAIS" : // Français
 Nation(nationFrançais)
CAS "ANGLAIS" : // Anglais
 Nation(nationAnglais)
 SI ChargeErreur("ANGLAIS.WDM")>0 ALORS
Erreur("Fichier des messages non trouvé." , ...
 "Messages affichés en français.")
 FIN
CAS "ESPAGNOL" : // Espagnol
 Nation(nationEspagnol)
 SI ChargeErreur("ESPAGNOL.WDM")>0 ALORS
Erreur("Fichier des messages non trouvé.", ...
"Messages affichés en français.")
 FIN
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire