PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Utilisation d'une classe présente dans une WDL
ChargeWDL (Exemple)
Exemple : Utilisation d'une classe présente dans une WDL
L'exemple suivant permet de manipuler une classe présente dans une bibliothèque WINDEV chargée par la fonction ChargeWDL.
GLOBAL
        gObjExterne est un objet dynamique

LOCAL
        sErrCompil est une chaîne

SI ChargeWDL("MaBibliotheque.WDL") = -1 ALORS
        FinProgramme("WDL non chargée" + RC + ErreurInfo())
SINON
        Info("WDL chargée")
FIN

sErrCompil = Compile("AllouerObj", "gObjExterne=allouer un objet cObjWDL")
SI sErrCompil = "" ALORS
        ExécuteTraitement("AllouerObj", trtProcédure)
        Compile("AllouerObj", "")
        Info("Allocation Ok")
SINON
        FinProgramme("Pb d'allocation de l'objet" + RC + sErrCompil)
FIN
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire