PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Exemple : Compilation dynamique
  • Création par programmation de colonnes de table
Exemple : Compilation dynamique
WINDEVWindows MobileCode Utilisateur (MCU)
L'exemple suivant permet de créer dynamiquement une procédure en fonction des choix effectués par l'utilisateur. Cet exemple permet de saisir deux chiffres dans deux champs de saisie (SAI_Valeur1 et SAI_Valeur2) et de réaliser un calcul en fonction de l'option cochée dans le sélecteur.
// Exemple : opération sélectionnée dans sélecteur SEL_Opération
Res est une chaîne
CodeACompiler est une chaîne = "Résultat1 est un entier" + RC + ...
"Saisie2 est un entier" + RC
SELON SEL_Opération
CAS 1 : // Addition
CodeACompiler = CodeACompiler + ...
"Résultat1 = SAI_Valeur1+SAI_Valeur2" + RC + ...
"Saisie2 = SAI_Valeur1+SAI_Valeur2"
CAS 2 : // Soustraction
CodeACompiler = CodeACompiler + ...
"Résultat1 = SAI_Valeur1-SAI_Valeur2" + RC + ...
"Saisie2 = SAI_Valeur1-SAI_Valeur2"
CAS 3 : // Multiplication
CodeACompiler = CodeACompiler + ...
"Résultat1 = SAI_Valeur1*SAI_Valeur2" + RC + ...
"Saisie2 = SAI_Valeur1*SAI_Valeur2"
CAS 4 : // Division
CodeACompiler = CodeACompiler + ...
"Résultat1 = SAI_Valeur1/SAI_Valeur2" + RC + ...
"Saisie2 = SAI_Valeur1/SAI_Valeur2"
AUTRES CAS :
CodeACompiler = ""
FIN
SI CodeACompiler <> "" ALORS
CodeACompiler = CodeACompiler + RC + ...
"Info(""Résultat1 = "" + Résultat1, ""Saisie2= "" + Saisie2)"
Res = Compile("Calcule", CodeACompiler)
SI Res = "" ALORS
ExécuteTraitement("Calcule", trtProcédure)
SINON
Erreur("Erreur compilation dynamique", Res)
FIN
SINON
Erreur("Aucune fonction à compiler")
FIN
Création par programmation de colonnes de table
WINDEVWEBDEV - Code ServeurEtats et RequêtesWindowsWindows MobileCode Utilisateur (MCU)
MaChaîne est une chaîne
 
HLitPremier(CODEPOSTAUX, CodePostal)
POUR I = 1 À 5
MaChaîne = MaChaîne + RC + ...
"ChampClone(Colonne2, """ + CODEPOSTAUX.Ville + """)"
MaChaîne = MaChaîne + RC + ...
"{""Table1." + CODEPOSTAUX.Ville + ...
"""}..Libellé = """ + CODEPOSTAUX.Ville + """"
HLitSuivant(CODEPOSTAUX)
FIN
 
Compile("CreationColonnes", MaChaîne)
ExécuteTraitement("CreationColonnes", trtProcédure)
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire