DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Aide / WLangage / Fonctions WLangage / Fonctions spécifiques au WEB / Fonctions de gestion du navigateur
  • Exemple 1 : Vérifier si le navigateur accepte les cookies
  • Exemple 2 : Ecriture et lecture d'un cookie
CookieLit (Exemple)
Exemple 1 : Vérifier si le navigateur accepte les cookies
WEBDEV - Code NavigateurPHP Cet exemple permet de vérifier si le navigateur en cours accepte les cookies.
// -- Bouton/Lien avec "aucune" action serveur, événement onclick navigateur
// Vérifie si les cookies sont acceptés par le navigateur
 
// Ecriture d'un cookie dans un code navigateur
sValCookie est une chaîne
sValCookie = DateSys() + HeureSys()
CookieEcrit("TestCookieAcceptes", sValCookie)
// Relecture du cookie et vérification de la valeur lue
SI PAS sValCookie = CookieLit("TestCookieAcceptes") ALORS
// Cookies non acceptés
Erreur("Le navigateur n'accepte pas les cookies", ...
"Veuillez modifier les paramètres de votre navigateur" + ...
"pour accepter les cookies.")
SINON
// Cookies acceptés
Info("Cookies acceptés")
FIN
Exemple 2 : Ecriture et lecture d'un cookie
WEBDEV - Code ServeurPHPAjax Le code suivant écrit en code serveur un cookie pour indiquer la dernière utilisation. A la fin du code serveur, au retour au navigateur, le cookie sera mis à jour dans le navigateur de l'internaute.
Une seule écriture de cookie par traitement serveur est autorisée.
Le cookie pourra être lu dans une autre session (et uniquement dans une autre session).
// -- Clic sur un bouton/lien (code serveur)
// Ecriture d'un cookie en code serveur
CookieEcrit("LastUse", DateSys() + HeureSys())
Cet exemple permet de lire en code serveur la valeur d'un cookie d'une précédente session.
// Lecture d'un cookie en code serveur
// La fonction CookieLit permet uniquement
// de lire les cookies chargés en mémoire au début de la session.
// Il est donc impossible de lire les cookies écrits dans la session en cours.
 
// Le cookie doit avoir été écrit lors d'une précédente session
sValCookie est une chaîne
sValCookie = CookieLit("LastUse")
SI PAS sValCookie ~= "" ALORS
Info("La dernière utilisation est le : ", sValCookie)
FIN
Version minimum requise
  • Version 16
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire

Dernière modification : 25/05/2022

Signaler une erreur ou faire une suggestion | Aide en ligne locale