PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Cause
  • Correction
  • Exemples
  • Utilisation d'une instruction SI sur une ligne
  • Utilisation d'une instruction SI sur plusieurs lignes
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Erreur 25 : Il manque le ALORS associé à ce SI
Cause
Vous avez utilisé une instruction conditionnelle de type SI. Cette instruction doit comporter le mot-clé ALORS.
Correction
Vérifiez le code de votre instruction conditionnelle et ajoutez si nécessaire le mot-clé ALORS manquant.
Exemples

Utilisation d'une instruction SI sur une ligne

Code provoquant l'erreur
SI TABLE_Cours..Vide
        IMG_Dessiner..Etat = Grisé
Correction proposée
Ajoutez le mot-clé ALORS entre la condition et l'action à effectuer si la condition est remplie.
SI TABLE_Cours..Vide ALORS IMG_Dessiner..Etat = Grisé

Utilisation d'une instruction SI sur plusieurs lignes

Code provoquant l'erreur
SI TABLE_Cours..Vide
        IMG_Dessiner..Etat = Grisé
FIN
Correction proposée
Ajoutez le mot-clé ALORS entre la condition et l'action à effectuer si la condition est remplie.
SI TABLE_Cours..Vide ALORS
        IMG_Dessiner..Etat = Grisé
FIN
Version minimum requise
  • Version 0
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire