PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Cause
  • Correction
  • Exemples
  • Utilisation d'un BOUCLE sans FIN
  • Instructions imbriquées : une instruction BOUCLE et une instruction SI sont imbriquées
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Erreur 24 : Il manque le FIN associé à ce BOUCLE
Cause
Vous avez utilisé une instruction répétitive de type BOUCLE. Cette instruction doit se terminer par le mot-clé FIN.
Correction
Vérifiez le code de votre instruction répétitive et ajoutez si nécessaire le mot-clé FIN manquant.
Exemples

Utilisation d'un BOUCLE sans FIN

Code provoquant l'erreur
BOUCLE
       // Lecture d'une ligne du fichier texte
        UneLigne = fLitLigne(NumFic)
        SI UneLigne = EOT ALORS SORTIR
        TraiteLigne(UneLigne)


Correction proposée

Ajoutez le mot-clé FIN à la fin de la répétition.
BOUCLE
       // Lecture d'une ligne du fichier texte
        UneLigne = fLitLigne(NumFic)
        SI UneLigne = EOT ALORS SORTIR
        TraiteLigne(UneLigne)
FIN

Instructions imbriquées : une instruction BOUCLE et une instruction SI sont imbriquées

Code provoquant l'erreur
BOUCLE
       // Lecture d'une ligne du fichier texte
        UneLigne = fLitLigne(NumFic)
        SI UneLigne = EOT ALORS
                SORTIR
        TraiteLigne(UneLigne)
FIN
Correction proposée
Vérifiez que toutes les instructions imbriquées se terminent correctement (par l'instruction FIN par exemple). Dans notre exemple, l'instruction SI n'a pas de FIN associée. Ajoutez une instruction FIN.
BOUCLE
       // Lecture d'une ligne du fichier texte
        UneLigne = fLitLigne(NumFic)
        SI UneLigne = EOT ALORS
                SORTIR
        FIN
        TraiteLigne(UneLigne)
FIN
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire