PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Cause
  • Correction
  • Exemples
  • Utilisation d'un TANTQUE sans FIN
  • Instructions imbriquées : Une instruction TANTQUE et une instruction SI sont imbriquées
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Erreur 23 : Il manque le FIN associé à ce TANTQUE
Cause
Vous avez utilisé une instruction répétitive de type TANTQUE. Cette instruction doit se terminer par le mot-clé FIN.
Correction
Vérifiez le code de votre instruction répétitive et ajoutez si nécessaire le mot-clé FIN manquant.
Exemples

Utilisation d'un TANTQUE sans FIN

Code provoquant l'erreur
UneListe=INILit("Exemples", "", "", FichierINI)
MotClé = ExtraitChaîne(UneListe, nb, RC)
TANTQUE MotClé <> ""
nb = nb + 1
NomExpl = INILit("Projets installés", MotClé, "", FichierINI)
MotClé = ExtraitChaîne(UneListe, nb + 1, RC)
Correction proposée
Ajoutez le mot-clé FIN à la fin de la répétition.
UneListe = INILit("Exemples", "", "", FichierINI)
MotClé = ExtraitChaîne(UneListe, nb, RC)
TANTQUE MotClé <> ""
nb = nb + 1
NomExpl = INILit("Projets installés", MotClé, "", FichierINI)
MotClé = ExtraitChaîne(UneListe, nb + 1, RC)
FIN

Instructions imbriquées : Une instruction TANTQUE et une instruction SI sont imbriquées

Code provoquant l'erreur
TANTQUE I <> TABLE_TABLE1..Occurrence
I = I + 1
SI COL_LOGICIEL[I] = "WEBDEV" ALORS
TABLE_TABLE1[I][2]..CouleurFond = BleuClair
TABLE_TABLE1[I][2]..Couleur = JauneClair
FIN
Correction proposée
Vérifiez que toutes les instructions imbriquées se terminent correctement (par l'instruction FIN par exemple). Dans notre exemple, l'instruction SI n'a pas de FIN associée. Ajoutez une instruction FIN.
TANTQUE I <> TABLE_TABLE1..Occurrence
I = I + 1
SI COL_LOGICIEL[I] = "WEBDEV" ALORS
TABLE_TABLE1[I][2]..CouleurFond = BleuClair
TABLE_TABLE1[I][2]..Couleur = JauneClair
FIN
FIN
Version minimum requise
  • Version 0
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire