DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Source de données dans une boucle
Source de données (Exemple)
Source de données dans une boucle
Cet exemple utilise une source de données dans une boucle : un nom unique est créé pour chaque source de données.
// Variable source de données
sdMaVue est une Source de Données
// Liste des vues créées
sListeDesVue est un Liste de chaîne
// Une vue par lettre de l'alphabet
POUR nNumLettre = 0 À 25
// Nom unique pour la source de données
sdMaVue = "Vue" + DateSys() + HeureSys() + DonneIdentifiant()
// Mémorise le nom dans une liste
Ajoute(sListeDesVue, sdMaVue)
// Initialisation de la variable MaVue
HCréeVue(sdMaVue, CLIENT, "*", "NOM,VILLE", "NOM]='" + ...
Caract(Asc("A") + nNumLettre) + "'", hVueDéfaut)
FIN
 
// Traitements sur les 26 vues
 
 
// Destruction des vues créées
POUR TOUT sNomUneVue DE sListeDesVue
HDétruitVue(sNomUneVue)
FIN
SupprimeTout(sListeDesVue)
Version minimum requise
  • Version 16
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire