PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE


  • Cause
  • Correction
  • Exemple
  • Utilisation d'un membre protégé dans le code de clic d'un bouton
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Erreur 1008 : Le membre de la classe est protégé
Cause
Vous tentez d'accéder à un membre protégé de la classe à partir d'un code autre qu'un code de la classe ou d'une classe dérivée.
Rappel : Un membre protégé peut être manipulé uniquement à partir d'un code de la classe ou d'une classe dérivée de cette classe.
Correction
Deux possibilités :
  • Remplacer le membre protégé par :
    • Un membre protégé constant : Il sera possible de lire et modifier la valeur du membre depuis l'intérieur de la classe, de lire la valeur du membre depuis une classe dérivée. L'accès au membre sera interdit depuis tout autre endroit du code.
    • Un membre public constant : Il sera possible de lire et modifier la valeur du membre depuis l'intérieur de la classe ou depuis une classe dérivée. Il sera uniquement possible de lire la valeur du membre depuis tout autre endroit du code.
    • Un membre public : L'accès au membre ne sera pas restreint.
  • Ne pas manipuler ce membre protégé depuis un des codes du projet.
Exemple

Utilisation d'un membre protégé dans le code de clic d'un bouton

Code provoquant l'erreur
// -- Déclaration de la classe
Dessin est une Classe
PROTÉGÉ
CouleurBase est un entier  // Couleur
FIN

// -- Code de clic d'un bouton
SI Dessin::CouleurBase = RougeClair ALORS
...
Correction proposée
Utiliser un membre public constant.
// -- Déclaration de la classe
Dessin est une Classe
PUBLIC CONSTANT
CouleurBase est un entier  // Couleur
FIN

// -- Code de clic d'un bouton
SI Dessin::CouleurBase = RougeClair ALORS
...
Version minimum requise
  • Version 0
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire