PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Présentation
  • Onglet télémétrie
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
La fenêtre de description du projet permet de configurer de nombreux éléments de votre projet. Cette fenêtre est constituée des onglets suivants :
  • L'onglet "Projet" qui permet de saisir les informations générales du projet
  • L'onglet "Analyse" qui permet d'associer une analyse au projet et/ou un modèle UML
  • L'onglet "Fichiers" qui permet de saisir différentes informations sur les fichiers de données gérés par l'application (uniquement disponible si le projet est lié à une analyse).
  • L'onglet "Live data" qui permet de configurer l'affichage des données (provenant des fichiers de données) sous les différents éditeurs.
  • L'onglet "Langues" qui permet de paramétrer les différentes langues manipulées par le projet ainsi que les options linguistiques à utiliser pour chaque langue.
  • L'onglet "Style" qui permet de choisir le thème de gabarit, la feuille de styles personnalisée et de personnaliser l'aperçu avant impression. Il est également possible de paramétrer la taille des écrans.
  • L'onglet "Groupe" qui permet de gérer le travail en groupe (Groupware développeur ou GDS).
  • L'onglet "Options" qui permet de configurer les options de mise à jour, de sauvegarde, de synchronisation des modèles. Cet onglet permet également d'activer le mode strict et de définir la charte de programmation.
  • L'onglet "Avancé" qui permet de gérer l'utilisation de "Etats & Requêtes", les FAA et le verrouillage de l'application.
  • L'onglet "Compilation" qui permet de configurer les options de compilation.
  • L'onglet "Télémétrie" qui permet de configurer les options de télémétrie pour le projet.
Onglet télémétrie
Cet onglet permet d'activer la télémétrie dans un projet et dans toutes les configurations de projet liées.
Pour activer la télémétrie :
  1. Cochez l'option "Activez la télémétrie pour le projet".
  2. Renseignez les différents paramètres demandés :
    Description du projet, onglet
    • Localisation du serveur :
      • Serveur local, réseau ou Internet : Dans ce cas, vous pouvez préciser le protocole utilisé : HTPP ou HTTPS.
        Remarque : Dans le cas d'un protocole HTTPS, il est nécessaire d'installer un certificat sur votre serveur Web (IIS ou Apache).
      • Plateforme de télémetrie CLOUD. Dans ce cas, il suffit de préciser le compte CLOUD à utiliser.
        Remarque : Une plateforme de type Télémétrie est nécessaire. Pour plus de détails, consultez PCSCloud.
    • Adresse :
      • Adresse du serveur ou de la plateforme PCCloud,
      • Nom de l'utilisateur et mot de passe associé. Ces données ont été fournies à la fin de l'installation du serveur de télémétrie.
        Versions 23 et supérieures
        Remarque : Il est possible de mémoriser le mot de passe.
        Nouveauté 23
        Remarque : Il est possible de mémoriser le mot de passe.
        Remarque : Il est possible de mémoriser le mot de passe.
      Testez la connexion au serveur de télémétrie pour vérifier que les données sont exactes.
    • Télémétrie de l'application :
      • Nom de l'application. Ce nom sera proposé dans le tableau de bord de la télémétrie.
      • Le mode de déclenchement de la collecte des informations. Par défaut, la collecte des données est activée automatiquement mais il est possible de l'activer par programmation grâce à la fonction TélémétrieActive.
  3. Validez.
Ces paramètres sont définis pour le projet en cours et toutes ses configurations. Il est possible au niveau de chaque configuration de projet de personnaliser ou de désactiver la télémétrie.
Version minimum requise
  • Version 22
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire