PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Présentation
  • Onglet "Langues"
  • Langues du projet
  • Options linguistiques
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
La fenêtre de description du projet permet de configurer de nombreux éléments de votre projet. Cette fenêtre est constituée des onglets suivants :
  • L'onglet "Projet" qui permet de saisir les informations générales du projet
  • L'onglet "Analyse" qui permet d'associer une analyse au projet et / ou un modèle UML
  • L'onglet "Fichiers" qui permet de saisir différentes informations sur les fichiers de données gérés par l'application (uniquement disponible si le projet est lié à une analyse).
  • L'onglet "Live data" qui permet de configurer l'affichage des données (provenant des fichiers de données) sous les différents éditeurs.
  • L'onglet "Langues" qui permet de paramétrer les différentes langues manipulées par le projet ainsi que les options linguistiques à utiliser pour chaque langue.
  • L'onglet "Style" qui permet de choisir le thème de gabarit, la feuille de styles personnalisée et de personnaliser l'aperçu avant impression. Il est également possible de paramétrer la taille des écrans.
  • L'onglet "Groupe" qui permet de gérer le travail en groupe (Groupware développeur ou GDS).
  • L'onglet "Options" qui permet de configurer les options de mise à jour, de sauvegarde, de synchronisation des modèles. Cet onglet permet également d'activer le mode strict et de définir la charte de programmation.
  • L'onglet "Avancé" qui permet de gérer l'utilisation de "Etats & Requêtes", les FAA et le verrouillage de l'application.
  • L'onglet "Compilation" qui permet de configurer les options de compilation.
  • Versions 22 et supérieures
    L'onglet "Télémétrie" qui permet de configurer les options de télémétrie pour le projet.
    WEBDEV - Code Serveur Cette option n'est pas disponible.
    Nouveauté 22
    L'onglet "Télémétrie" qui permet de configurer les options de télémétrie pour le projet.
    WEBDEV - Code Serveur Cette option n'est pas disponible.
    L'onglet "Télémétrie" qui permet de configurer les options de télémétrie pour le projet.
    WEBDEV - Code Serveur Cette option n'est pas disponible.
Onglet "Langues"

Langues du projet

Cet onglet permet de gérer les caractéristiques des différentes langues du projet.
Pour ajouter une nouvelle langue dans le projet :
  1. Cliquez sur le bouton "Ajouter".
  2. Dans la fenêtre qui s'affiche, sélectionnez les différentes langues gérées par le projet.
    Remarques :
    • Si la langue voulue n'apparaît pas dans la liste, il est possible de sélectionner une langue supplémentaire (les langues supplémentaires sont affichées dans la partie basse de la fenêtre).
    • Versions 21 et supérieures
      Pour nommer une langue supplémentaire, cliquez sur la langue voulue et saisissez son nom dans la zone "Nom des langues personnalisées".
      Nouveauté 21
      Pour nommer une langue supplémentaire, cliquez sur la langue voulue et saisissez son nom dans la zone "Nom des langues personnalisées".
      Pour nommer une langue supplémentaire, cliquez sur la langue voulue et saisissez son nom dans la zone "Nom des langues personnalisées".
  3. Validez. Les différentes langues sont ajoutées dans la liste des langues du projet.
Remarques :
  • Les langues sélectionnées seront proposées pour toutes les informations des différents éléments pouvant être traduites (libellés des champs, options de menus, messages d'aide associés à un champ, ...). L'ordre d'affichage de ces langues est identique à celui de la liste des langues du projet.
    Versions 21 et supérieures
    Il est possible de modifier cet ordre à l'aide des boutons fléchés présents sous la liste des langues du projet.
    Nouveauté 21
    Il est possible de modifier cet ordre à l'aide des boutons fléchés présents sous la liste des langues du projet.
    Il est possible de modifier cet ordre à l'aide des boutons fléchés présents sous la liste des langues du projet.
  • Lors de la modification des différentes langues du projet, les modifications seront automatiquement prises en compte :
    • pour tout nouvel objet créé sous les différents éditeurs (Fenêtre, Etat, Champ, ...).
    • pour tout élément ouvert sous les différents éditeurs (Fenêtre, Etat, ...).
La langue par défaut (identifiée par le numéro "1") correspond à la langue utilisée par défaut en exécution. Pour la modifier, utilisez le menu contextuel de la langue à utiliser par défaut.

Options linguistiques

Il est possible de paramétrer l'affichage des différentes données numériques du projet (nombre, monétaire, date, ...) dans chaque langue gérée par le projet.
Par défaut, les paramètres utilisés sont ceux définis dans les options linguistiques de Windows (accessible depuis le panneau de configuration de Windows).
Pour paramétrer ces options :
  1. Sélectionnez la langue voulue dans la partie gauche de l'écran.
  2. Sélectionnez l'onglet correspondant à l'élément à paramétrer (nombre, monétaire, ...).
  3. Modifiez les paramètres voulus et validez.
Remarque : Un bouton permet à tout moment de réinitialiser les paramètres avec les valeurs par défaut.
Lors de la création d'un champ de saisie ou d'une colonne de table affichant des données de type numérique (nombre, monétaire, date, heure, durée, ...), le masque de saisie utilisé sera automatiquement le masque défini dans les options de langue du projet. Cette option est disponible dans les fenêtres et les pages.
En exécution, lorsque un champ de saisie ou une colonne de table a pour masque "Défini par le projet", le masque de saisie / d'affichage s'adaptera automatiquement selon les options choisies dans le projet pour la langue affichée en exécution.
Remarque : L'option "Divers" permet de définir :
  • le sens d'écriture.
  • l'alphabet utilisé.
  • le fichier WDM de traduction.
Versions 18 et supérieures
Java Les options linguistiques supportées sont les suivantes :
  • Séparateur de décimales (nombre et monétaire)
  • Séparateur de milliers (nombre et monétaire)
  • Symbole monétaire
  • Format d'heure
  • Format de date
  • Jour et Mois
  • Unité des tailles de fichier
Nouveauté 18
Java Les options linguistiques supportées sont les suivantes :
  • Séparateur de décimales (nombre et monétaire)
  • Séparateur de milliers (nombre et monétaire)
  • Symbole monétaire
  • Format d'heure
  • Format de date
  • Jour et Mois
  • Unité des tailles de fichier
Java Les options linguistiques supportées sont les suivantes :
  • Séparateur de décimales (nombre et monétaire)
  • Séparateur de milliers (nombre et monétaire)
  • Symbole monétaire
  • Format d'heure
  • Format de date
  • Jour et Mois
  • Unité des tailles de fichier
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire