PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Présentation
  • Onglet Compilation
  • Options générales
  • Erreurs d'IHM
  • Compilation multi-configuration
  • Norme de programmation
  • Compilation des identificateurs inconnus
  • Options de compilation
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
La fenêtre de description du projet permet de configurer de nombreux éléments de votre projet. Cette fenêtre est constituée des onglets suivants :
  • L'onglet "Projet" qui permet de saisir les informations générales du projet
  • L'onglet "Analyse" qui permet d'associer une analyse au projet et / ou un modèle UML
  • L'onglet "Fichiers" qui permet de saisir différentes informations sur les fichiers de données gérés par l'application (uniquement disponible si le projet est lié à une analyse).
  • L'onglet "Live data" qui permet de configurer l'affichage des données (provenant des fichiers de données) sous les différents éditeurs.
  • L'onglet "Langues" qui permet de paramétrer les différentes langues manipulées par le projet ainsi que les options linguistiques à utiliser pour chaque langue.
  • L'onglet "Style" qui permet de choisir le thème de gabarit, la feuille de styles personnalisée et de personnaliser l'aperçu avant impression. Il est également possible de paramétrer la taille des écrans.
  • L'onglet "Groupe" qui permet de gérer le travail en groupe (Groupware développeur ou GDS).
  • L'onglet "Options" qui permet de configurer les options de mise à jour, de sauvegarde, de synchronisation des modèles. Cet onglet permet également d'activer le mode strict et de définir la charte de programmation.
  • L'onglet "Avancé" qui permet de gérer l'utilisation de "Etats & Requêtes", les FAA et le verrouillage de l'application.
  • L'onglet "Compilation" qui permet de configurer les options de compilation.
  • Versions 22 et supérieures
    L'onglet "Télémétrie" qui permet de configurer les options de télémétrie pour le projet.
    WEBDEV - Code Serveur Cette option n'est pas disponible.
    Nouveauté 22
    L'onglet "Télémétrie" qui permet de configurer les options de télémétrie pour le projet.
    WEBDEV - Code Serveur Cette option n'est pas disponible.
    L'onglet "Télémétrie" qui permet de configurer les options de télémétrie pour le projet.
    WEBDEV - Code Serveur Cette option n'est pas disponible.
Onglet Compilation

Options générales

Les options générales sont les suivantes :
  • Répertoire de compilation : Le répertoire des codes compilés de l'application est créé dans un sous-répertoire "<Nom_Projet>.cpl" du répertoire de compilation. Ce répertoire des codes compilés contient :
    • Les fichiers des codes compilés de chaque élément du projet : fenêtres, états, requêtes, etc.
    • Un sous-répertoire par développeur intervenant sur le projet. Ce répertoire correspond au nom du développeur. Pour plus de détails, consultez Partager le développement d'un projet.
      Par défaut, le répertoire de compilation correspond au répertoire du projet. Il est possible de compiler tous vos projets dans le même répertoire : il suffit d'indiquer le même répertoire de compilation pour tous vos projets.
  • Recompiler le projet avant la génération des applications, des bibliothèques, ... :
    Cette option permet de forcer la recompilation du projet avant chaque opération majeure sur le projet. Cette option est notamment conseillée lors de la génération multiple à partir d'un projet.
    Cette option est également proposée dans tous les assistants permettant de réaliser une opération de déploiement (création d'exécutable, de bibliothèque, génération multiple, ...).
  • WEBDEV - Code Serveur Afficher les erreurs de compilation relatives au système Linux : Permet d'indiquer que le projet va être déployé sous Linux. Les erreurs de compilation spécifiques à une utilisation sous Linux sont affichées.
  • Versions 20 et supérieures
    WEBDEV - Code Serveur Afficher les erreurs de compilation relatives aux sessions prélancées : Si votre projet utilise des sessions prélancées, certaines fonctions ne peuvent plus être utilisées lors de l'initialisation du projet. Cette option permet de connaître les problèmes potentiels lors de l'utilisation des sessions prélancées. Pour plus de détails, consultez Les sessions prélancées.
    Nouveauté 20
    WEBDEV - Code Serveur Afficher les erreurs de compilation relatives aux sessions prélancées : Si votre projet utilise des sessions prélancées, certaines fonctions ne peuvent plus être utilisées lors de l'initialisation du projet. Cette option permet de connaître les problèmes potentiels lors de l'utilisation des sessions prélancées. Pour plus de détails, consultez Les sessions prélancées.
    WEBDEV - Code Serveur Afficher les erreurs de compilation relatives aux sessions prélancées : Si votre projet utilise des sessions prélancées, certaines fonctions ne peuvent plus être utilisées lors de l'initialisation du projet. Cette option permet de connaître les problèmes potentiels lors de l'utilisation des sessions prélancées. Pour plus de détails, consultez Les sessions prélancées.
  • Recompilation du projet pour mettre en phase les IHM et le code :
    Une recompilation est souvent nécessaire pour mettre en phase l'interface et le code, par exemple lorsque le nom d'un élément a été modifié, le code d'un élément a été modifié, ... Il est possible :
    • soit de toujours proposer la recompilation : un message s'affiche et demande au développeur si la compilation doit être effectuée. Il est possible de différer la compilation pour l'effectuer plus tard.
    • soit de toujours faire la compilation sans demander. Si cette option est cochée, des ralentissements peuvent être provoqués par la recompilation.
  • Versions 22 et supérieures
    WEBDEV - Code Serveur WLangage navigateur : Permet de choisir le framework navigateur utilisé pour le projet. A partir de la version 22, WEBDEV propose un nouveau framework WLangage pour le code navigateur. Cette nouvelle version offre un comportement beaucoup plus proche du code serveur et complète largement les fonctionnalités du code navigateur.
    Important : pour utiliser le nouveau framework WLangage, la norme de génération des pages doit être définie en "HTML 5".
    Nouveauté 22
    WEBDEV - Code Serveur WLangage navigateur : Permet de choisir le framework navigateur utilisé pour le projet. A partir de la version 22, WEBDEV propose un nouveau framework WLangage pour le code navigateur. Cette nouvelle version offre un comportement beaucoup plus proche du code serveur et complète largement les fonctionnalités du code navigateur.
    Important : pour utiliser le nouveau framework WLangage, la norme de génération des pages doit être définie en "HTML 5".
    WEBDEV - Code Serveur WLangage navigateur : Permet de choisir le framework navigateur utilisé pour le projet. A partir de la version 22, WEBDEV propose un nouveau framework WLangage pour le code navigateur. Cette nouvelle version offre un comportement beaucoup plus proche du code serveur et complète largement les fonctionnalités du code navigateur.
    Important : pour utiliser le nouveau framework WLangage, la norme de génération des pages doit être définie en "HTML 5".

Erreurs d'IHM

Les erreurs de compilation d'IHM vous informent à chaque sauvegarde de fenêtre, de page, d'état ou à chaque recompilation du projet des problèmes potentiels détectés sur vos interfaces.
Par défaut, les erreurs de compilation d'IHM sont activées pour chaque nouveau projet créé.
Versions 22 et supérieures
Le bouton "Editer les langues" permet de choisir les langues du projet qui seront prises en compte par la compilation d'IHM.
Nouveauté 22
Le bouton "Editer les langues" permet de choisir les langues du projet qui seront prises en compte par la compilation d'IHM.
Le bouton "Editer les langues" permet de choisir les langues du projet qui seront prises en compte par la compilation d'IHM.
Pour plus de détails, consultez Erreurs de compilation d'IHM.
Versions 22 et supérieures

Compilation multi-configuration

Si l'option "Activer la compilation multi-configuration" est cochée, toutes les configurations du projet seront systématiquement compilées.
Ainsi, les éventuelles erreurs de compilation dans une configuration donnée apparaissent immédiatement.
Cette option est très utile par exemple pour un projet WINDEV Mobile disponible sous Android et iPhone/iPad.
Rappel : le projet est compilé à chaque retour de ligne dans l'éditeur de code, à chaque sauvegarde (Ctrl + S), ...
Nouveauté 22

Compilation multi-configuration

Si l'option "Activer la compilation multi-configuration" est cochée, toutes les configurations du projet seront systématiquement compilées.
Ainsi, les éventuelles erreurs de compilation dans une configuration donnée apparaissent immédiatement.
Cette option est très utile par exemple pour un projet WINDEV Mobile disponible sous Android et iPhone/iPad.
Rappel : le projet est compilé à chaque retour de ligne dans l'éditeur de code, à chaque sauvegarde (Ctrl + S), ...

Compilation multi-configuration

Si l'option "Activer la compilation multi-configuration" est cochée, toutes les configurations du projet seront systématiquement compilées.
Ainsi, les éventuelles erreurs de compilation dans une configuration donnée apparaissent immédiatement.
Cette option est très utile par exemple pour un projet WINDEV Mobile disponible sous Android et iPhone/iPad.
Rappel : le projet est compilé à chaque retour de ligne dans l'éditeur de code, à chaque sauvegarde (Ctrl + S), ...
Versions 23 et supérieures

Norme de programmation

Ces options permettent de définir une norme de programmation. Les "erreurs" de norme de programmation signalent les lignes de code ne respectant pas cette norme. Ces erreurs sont affichées dans le volet "Erreurs de compilation".
Les options disponibles sont :
  • Signaler les fonctions WLangage conservées par compatibilité : Si cette option est cochée, les fonctions WLangage conservées uniquement par compatibilité sont indiquées dans les erreurs de norme de programmation (par exemple, la fonction ArbreTri).
    Rappel : Les fonctions conservées par compatibilité peuvent ne plus être supportées dans une prochaine version. Il est conseillé d'utiliser la nouvelle fonction correspondante.
  • Signaler les accès à HFSQL depuis les fenêtres, pages et états : Si cette option est cochée, tous les accès aux fichiers de données HFSQL sont indiqués dans les erreurs de norme de programmation.
    Cette option permet d'isoler rapidement les accès à la base de données. En effet, dans certaines architectures de programmation, les accès à la base de données ne doivent pas être effectués depuis l'interface. Ces accès doivent être effectués dans du code métier depuis des procédures ou des classes.
  • Signaler les utilisations de la syntaxe objet ("ChampListe.Ajoute" par exemple) : Si cette option est cochée, toutes les utilisations de la syntaxe objet du WLangage disponibles depuis la version 23 seront signalées dans les erreurs de norme de programmation. Si cette syntaxe n'est pas autorisée dans le projet, il sera ainsi facile de retrouver ses utilisations.
Ces options peuvent être surchargées au niveau des composants internes, des fenêtres et des états. Pour plus de détails, consultez "Erreurs de norme de programmation".
Nouveauté 23

Norme de programmation

Ces options permettent de définir une norme de programmation. Les "erreurs" de norme de programmation signalent les lignes de code ne respectant pas cette norme. Ces erreurs sont affichées dans le volet "Erreurs de compilation".
Les options disponibles sont :
  • Signaler les fonctions WLangage conservées par compatibilité : Si cette option est cochée, les fonctions WLangage conservées uniquement par compatibilité sont indiquées dans les erreurs de norme de programmation (par exemple, la fonction ArbreTri).
    Rappel : Les fonctions conservées par compatibilité peuvent ne plus être supportées dans une prochaine version. Il est conseillé d'utiliser la nouvelle fonction correspondante.
  • Signaler les accès à HFSQL depuis les fenêtres, pages et états : Si cette option est cochée, tous les accès aux fichiers de données HFSQL sont indiqués dans les erreurs de norme de programmation.
    Cette option permet d'isoler rapidement les accès à la base de données. En effet, dans certaines architectures de programmation, les accès à la base de données ne doivent pas être effectués depuis l'interface. Ces accès doivent être effectués dans du code métier depuis des procédures ou des classes.
  • Signaler les utilisations de la syntaxe objet ("ChampListe.Ajoute" par exemple) : Si cette option est cochée, toutes les utilisations de la syntaxe objet du WLangage disponibles depuis la version 23 seront signalées dans les erreurs de norme de programmation. Si cette syntaxe n'est pas autorisée dans le projet, il sera ainsi facile de retrouver ses utilisations.
Ces options peuvent être surchargées au niveau des composants internes, des fenêtres et des états. Pour plus de détails, consultez "Erreurs de norme de programmation".

Norme de programmation

Ces options permettent de définir une norme de programmation. Les "erreurs" de norme de programmation signalent les lignes de code ne respectant pas cette norme. Ces erreurs sont affichées dans le volet "Erreurs de compilation".
Les options disponibles sont :
  • Signaler les fonctions WLangage conservées par compatibilité : Si cette option est cochée, les fonctions WLangage conservées uniquement par compatibilité sont indiquées dans les erreurs de norme de programmation (par exemple, la fonction ArbreTri).
    Rappel : Les fonctions conservées par compatibilité peuvent ne plus être supportées dans une prochaine version. Il est conseillé d'utiliser la nouvelle fonction correspondante.
  • Signaler les accès à HFSQL depuis les fenêtres, pages et états : Si cette option est cochée, tous les accès aux fichiers de données HFSQL sont indiqués dans les erreurs de norme de programmation.
    Cette option permet d'isoler rapidement les accès à la base de données. En effet, dans certaines architectures de programmation, les accès à la base de données ne doivent pas être effectués depuis l'interface. Ces accès doivent être effectués dans du code métier depuis des procédures ou des classes.
  • Signaler les utilisations de la syntaxe objet ("ChampListe.Ajoute" par exemple) : Si cette option est cochée, toutes les utilisations de la syntaxe objet du WLangage disponibles depuis la version 23 seront signalées dans les erreurs de norme de programmation. Si cette syntaxe n'est pas autorisée dans le projet, il sera ainsi facile de retrouver ses utilisations.
Ces options peuvent être surchargées au niveau des composants internes, des fenêtres et des états. Pour plus de détails, consultez "Erreurs de norme de programmation".

Compilation des identificateurs inconnus

Cette option permet de définir le type d'information affichée lorsque le compilateur rencontre un identificateur (nom de fenêtre, de champ, ...) inconnu.
Deux modes de gestion sont disponibles :
  • Mode rigoureux (par défaut) : Une erreur de compilation est affichée.
  • Mode permissif : une déclaration implicite est effectuée et un warning est affiché. Ce mode peut provoquer des erreurs en exécution.

Options de compilation

Les options de compilation disponibles sont les suivantes :
  • Erreur de compilation sur les identificateurs inconnus : Permet de définir si une erreur de compilation est affichée lorsque le compilateur rencontre un identificateur (nom de fenêtre, de champ, ...) inconnu.
  • Versions 21 et supérieures
    Erreur de compilation sur les éléments hors configuration
    Lorsque cette option est active, une erreur de compilation apparaît lors de l'utilisation dans le code lié à une configuration d'éléments hors configuration. L'instruction de compilation <COMPILE SI> permet de gérer la compilation du code selon les plateformes et les types de configuration.
    Nouveauté 21
    Erreur de compilation sur les éléments hors configuration
    Lorsque cette option est active, une erreur de compilation apparaît lors de l'utilisation dans le code lié à une configuration d'éléments hors configuration. L'instruction de compilation <COMPILE SI> permet de gérer la compilation du code selon les plateformes et les types de configuration.
    Erreur de compilation sur les éléments hors configuration
    Lorsque cette option est active, une erreur de compilation apparaît lors de l'utilisation dans le code lié à une configuration d'éléments hors configuration. L'instruction de compilation <COMPILE SI> permet de gérer la compilation du code selon les plateformes et les types de configuration.
  • Versions 18 et supérieures
    Portée des variables locales limitée au bloc courant
    Si cette option est sélectionnée, les variables locales sont localisées au bloc.
    Il n'est pas possible d'utiliser une variable locale à l'extérieur du bloc dans lequel elle est déclarée.
    La terminaison de la variable est exécutée à la fin du bloc (destructeurs et libération mémoire).
    Il est possible de redéclarer une variable de même nom dans deux sous-blocs distincts mais il n'est pas possible de redéclarer une variable de même nom dans un sous-bloc fils.
    Nouveauté 18
    Portée des variables locales limitée au bloc courant
    Si cette option est sélectionnée, les variables locales sont localisées au bloc.
    Il n'est pas possible d'utiliser une variable locale à l'extérieur du bloc dans lequel elle est déclarée.
    La terminaison de la variable est exécutée à la fin du bloc (destructeurs et libération mémoire).
    Il est possible de redéclarer une variable de même nom dans deux sous-blocs distincts mais il n'est pas possible de redéclarer une variable de même nom dans un sous-bloc fils.
    Portée des variables locales limitée au bloc courant
    Si cette option est sélectionnée, les variables locales sont localisées au bloc.
    Il n'est pas possible d'utiliser une variable locale à l'extérieur du bloc dans lequel elle est déclarée.
    La terminaison de la variable est exécutée à la fin du bloc (destructeurs et libération mémoire).
    Il est possible de redéclarer une variable de même nom dans deux sous-blocs distincts mais il n'est pas possible de redéclarer une variable de même nom dans un sous-bloc fils.
  • Versions 22 et supérieures
    Autoriser "[% %]" dans les chaînes : Cette option permet d'autoriser la saisie directe d'un nom de variable dans une chaîne de caractères (également appelée "construction dynamique des chaînes"). Il suffit d'utiliser la syntaxe suivante :
    [%Nomdevariable%]
    Par exemple :
    // Demande de confirmation du client
    SI OuiNon(Oui, "Confirmez-vous la création du client [%sNomClient%]") = Non ALORS
    RETOUR
    FIN
    Attention : l'utilisation de cette option peut impliquer la modification du code pour certaines fonctions WLangage utilisant déjà les caractères "[% %]" dans leurs paramètres. Dans ce cas, pour ne pas interpréter les caractères "[% %]", il est nécessaire de les faire précéder par "-%". Exemple :
    grBulle(GR_Echéance, grFormatBulle, "[%CATEGORIE%]" + RC + RC+ "[%VALEUR%]" + " H")
    devient
    grBulle(GR_Echéance, grFormatBulle, -%"[%CATEGORIE%]" + RC + RC + -%"[%VALEUR%]" + " H")
    Nouveauté 22
    Autoriser "[% %]" dans les chaînes : Cette option permet d'autoriser la saisie directe d'un nom de variable dans une chaîne de caractères (également appelée "construction dynamique des chaînes"). Il suffit d'utiliser la syntaxe suivante :
    [%Nomdevariable%]
    Par exemple :
    // Demande de confirmation du client
    SI OuiNon(Oui, "Confirmez-vous la création du client [%sNomClient%]") = Non ALORS
    RETOUR
    FIN
    Attention : l'utilisation de cette option peut impliquer la modification du code pour certaines fonctions WLangage utilisant déjà les caractères "[% %]" dans leurs paramètres. Dans ce cas, pour ne pas interpréter les caractères "[% %]", il est nécessaire de les faire précéder par "-%". Exemple :
    grBulle(GR_Echéance, grFormatBulle, "[%CATEGORIE%]" + RC + RC+ "[%VALEUR%]" + " H")
    devient
    grBulle(GR_Echéance, grFormatBulle, -%"[%CATEGORIE%]" + RC + RC + -%"[%VALEUR%]" + " H")
    Autoriser "[% %]" dans les chaînes : Cette option permet d'autoriser la saisie directe d'un nom de variable dans une chaîne de caractères (également appelée "construction dynamique des chaînes"). Il suffit d'utiliser la syntaxe suivante :
    [%Nomdevariable%]
    Par exemple :
    // Demande de confirmation du client
    SI OuiNon(Oui, "Confirmez-vous la création du client [%sNomClient%]") = Non ALORS
    RETOUR
    FIN
    Attention : l'utilisation de cette option peut impliquer la modification du code pour certaines fonctions WLangage utilisant déjà les caractères "[% %]" dans leurs paramètres. Dans ce cas, pour ne pas interpréter les caractères "[% %]", il est nécessaire de les faire précéder par "-%". Exemple :
    grBulle(GR_Echéance, grFormatBulle, "[%CATEGORIE%]" + RC + RC+ "[%VALEUR%]" + " H")
    devient
    grBulle(GR_Echéance, grFormatBulle, -%"[%CATEGORIE%]" + RC + RC + -%"[%VALEUR%]" + " H")
  • Versions 22 et supérieures
    Nommage automatique des sources de données
    Par défaut, les variables de type "Source de données" créent une source de donnée utilisant le nom de la variable.
    Cela peut poser un problème dans les cas suivants :
    • utilisation de tableaux de sources de données
    • utilisation de sources de données en tant que membres de classe.
    • lorsque deux fenêtres utilisent la même variable de type source de données.
    Cette option permet d'utiliser un nom unique pour la source de données. Attention : les guillemets doivent être supprimés pour manipuler la source de données. Il ne faut plus écrire :
    M1 est une source de données
    HLitPremier("M1")
    mais
    M1 est une source de données
    HLitPremier(M1)
    Nouveauté 22
    Nommage automatique des sources de données
    Par défaut, les variables de type "Source de données" créent une source de donnée utilisant le nom de la variable.
    Cela peut poser un problème dans les cas suivants :
    • utilisation de tableaux de sources de données
    • utilisation de sources de données en tant que membres de classe.
    • lorsque deux fenêtres utilisent la même variable de type source de données.
    Cette option permet d'utiliser un nom unique pour la source de données. Attention : les guillemets doivent être supprimés pour manipuler la source de données. Il ne faut plus écrire :
    M1 est une source de données
    HLitPremier("M1")
    mais
    M1 est une source de données
    HLitPremier(M1)
    Nommage automatique des sources de données
    Par défaut, les variables de type "Source de données" créent une source de donnée utilisant le nom de la variable.
    Cela peut poser un problème dans les cas suivants :
    • utilisation de tableaux de sources de données
    • utilisation de sources de données en tant que membres de classe.
    • lorsque deux fenêtres utilisent la même variable de type source de données.
    Cette option permet d'utiliser un nom unique pour la source de données. Attention : les guillemets doivent être supprimés pour manipuler la source de données. Il ne faut plus écrire :
    M1 est une source de données
    HLitPremier("M1")
    mais
    M1 est une source de données
    HLitPremier(M1)
  • Classes : préfixes ":" et "::" d'accès aux membres et aux méthodes facultatifs
    Jusqu'à la version 14, les accès aux membres devaient être faits en utilisant les préfixes ":" et "::". Si cette option est cochée, ces préfixes ne sont plus nécessaires.
  • Versions 18 et supérieures
    Classes : les méthodes de même nom sont automatiquement virtuelles.
    Les méthodes de même nom dans des classes dérivées sont automatiquement virtuelles.
    Le mode "semi-virtuelle" qui assurait la compatibilité avec WINDEV 4 et 5 n'est plus disponible.
    Le mot-clé "virtuelle" n'a plus aucun effet. Il n'y a plus de warning sur les méthodes virtuelles en l'absence du mot-clé "virtuelle".
    Nouveauté 18
    Classes : les méthodes de même nom sont automatiquement virtuelles.
    Les méthodes de même nom dans des classes dérivées sont automatiquement virtuelles.
    Le mode "semi-virtuelle" qui assurait la compatibilité avec WINDEV 4 et 5 n'est plus disponible.
    Le mot-clé "virtuelle" n'a plus aucun effet. Il n'y a plus de warning sur les méthodes virtuelles en l'absence du mot-clé "virtuelle".
    Classes : les méthodes de même nom sont automatiquement virtuelles.
    Les méthodes de même nom dans des classes dérivées sont automatiquement virtuelles.
    Le mode "semi-virtuelle" qui assurait la compatibilité avec WINDEV 4 et 5 n'est plus disponible.
    Le mot-clé "virtuelle" n'a plus aucun effet. Il n'y a plus de warning sur les méthodes virtuelles en l'absence du mot-clé "virtuelle".
  • Versions 18 et supérieures
    Tableaux : L'affectation copie le contenu
    Lorsque cette option est active, les tableaux sont locaux par défaut, c'est-à-dire que l'opérateur '=' fait une copie du tableau.
    Le mot-clé "dynamique" permet de conserver ponctuellement la prise de référence à l'affectation.
    Nouveauté 18
    Tableaux : L'affectation copie le contenu
    Lorsque cette option est active, les tableaux sont locaux par défaut, c'est-à-dire que l'opérateur '=' fait une copie du tableau.
    Le mot-clé "dynamique" permet de conserver ponctuellement la prise de référence à l'affectation.
    Tableaux : L'affectation copie le contenu
    Lorsque cette option est active, les tableaux sont locaux par défaut, c'est-à-dire que l'opérateur '=' fait une copie du tableau.
    Le mot-clé "dynamique" permet de conserver ponctuellement la prise de référence à l'affectation.
  • Versions 21 et supérieures
    Tableaux : accès protégé aux éléments passés en paramètre à une procédure
    Cette option permet de protéger un élément de tableau passé en paramètre à une procédure. Il devient ainsi possible de modifier, supprimer ou ajouter des éléments dans le tableau depuis cette procédure.
    Remarque : Si cette option est sélectionnée, les accès au tableau peuvent être légèrement ralentis.
    Nouveauté 21
    Tableaux : accès protégé aux éléments passés en paramètre à une procédure
    Cette option permet de protéger un élément de tableau passé en paramètre à une procédure. Il devient ainsi possible de modifier, supprimer ou ajouter des éléments dans le tableau depuis cette procédure.
    Remarque : Si cette option est sélectionnée, les accès au tableau peuvent être légèrement ralentis.
    Tableaux : accès protégé aux éléments passés en paramètre à une procédure
    Cette option permet de protéger un élément de tableau passé en paramètre à une procédure. Il devient ainsi possible de modifier, supprimer ou ajouter des éléments dans le tableau depuis cette procédure.
    Remarque : Si cette option est sélectionnée, les accès au tableau peuvent être légèrement ralentis.
AndroidJava Ces options de compilation sont prises en compte en Java et Android.
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire