PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Présentation
  • Actions réalisées par l'utilisateur
  • Constantes MK_XXX
  • Constantes VK_XXX
  • Constantes SB_XXX
  • Constantes SIZE_XXX
  • Exemples
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
WINDEV et WINDEV Mobile permettent d'ajouter simplement des traitements optionnels aux traitements proposés par défaut pour les différents éléments d'une application. Pour plus de détails, consultez Traitements optionnels.
Selon le traitement optionnel utilisé, il est possible de récupérer des informations spécifiques grâce aux variables _EVE.LPARAM et _EVE.WPARAM.
Actions réalisées par l'utilisateur
Le tableau suivant liste les différentes informations renvoyées dans les différents traitements optionnels :
Traitement optionnelInformation retournée dans la variable _EVE.LPARAMInformation retournée dans la variable _EVE.WPARAM
Survol de la souris (WM_MOUSEMOVE)

Bouton gauche de la souris enfoncé (WM_LBUTTONDOWN)

Bouton gauche de la souris relâché (WM_LBUTTONUP)

Double-clic avec le bouton gauche de la souris (WM_LBUTTONDBLCLK)

Bouton droit de la souris enfoncé (WM_RBUTTONDOWN)

Bouton droit de la souris relâché (WM_RBUTTONUP)

Double-clic avec le bouton droit de la souris (WM_RBUTTONDBLCLK)
  • Poids fort (connu par la fonction PoidsFort) : Position verticale (Y) du curseur de souris par rapport au champ ou à la fenêtre considérée (équivalent à la fonction SourisPosY).
  • Poids faible (connu par la fonction PoidsFaible) : Position horizontale (X) du curseur de souris par rapport au champ ou à la fenêtre considérée (équivalent à la fonction SourisPosX).
Touche enfoncée sous forme d'une constante MK_XXX
Roulette de la souris (WM_MOUSEWHEEL)
  • Poids fort (connu par la fonction PoidsFort) : Position verticale (Y) du curseur de souris par rapport au champ ou à la fenêtre considérée (équivalent à la fonction SourisPosY).
  • Poids faible (connu par la fonction PoidsFaible) : Position horizontale (X) du curseur de souris par rapport au champ ou à la fenêtre considérée (équivalent à la fonction SourisPosX).
  • Poids fort (connu par la fonction PoidsFort) : Sens de rotation de la roulette (nombre positif : déplacement vers le haut; nombre négatif : déplacement vers le bas)
  • Poids faible (connu par la fonction PoidsFaible) : Touche enfoncée sous forme d'une constante MK_XXX
Touche enfoncée (WM_KEYDOWN)
Touche relâchée (WM_KEYUP)
Touche enfoncée sous forme d'une constante VK_XXX
Touche appuyée (WM_CHAR)Code ASCII de la touche appuyée (manipulable avec la fonction Caract)
Touche système enfoncée (WM_SYSKEYDOWN)
Touche système relâchée (WM_SYSKEYUP)
Touche enfoncée sous forme d'une constante VK_XXX
Touche système appuyée (WM_SYSCHAR)Code ASCII de la touche système appuyée
Ascenseur horizontal (WM_HSCROLL)
Ascenseur vertical (WM_VSCROLL)
Handle de l'ascenseur
  • Poids fort (connu par la fonction PoidsFort) : Position de la cage de l'ascenseur
  • Poids faible (connu par la fonction PoidsFaible) : Méthode utilisée pour déplacer la cage de l'ascenseur, sous forme d'une constante SB_XXX
Affichage du menu contextuel (WM_CONTEXTMENU)
  • Poids fort (connu par la fonction PoidsFort) : Position verticale (Y) du curseur de souris par rapport au champ ou à la fenêtre considérée (équivalent à la fonction SourisPosY).
  • Poids faible (connu par la fonction PoidsFaible) : Position horizontale (X) du curseur de souris par rapport au champ ou à la fenêtre considérée (équivalent à la fonction SourisPosX).
Remarque : Si ces valeurs sont égales à -1, le menu contextuel a été ouvert à l'aide de la touche Windows d'ouverture de menu contextuel
Handle de la fenêtre ou du champ depuis lequel le menu contextuel est appelé
Déplacement (WM_MOVE)
  • Poids fort (connu par la fonction PoidsFort) :
    • soit la position verticale du coin haut gauche de la fenêtre par rapport au coin haut gauche de l'écran (équivalent à la propriété ..Y)
    • soit la position verticale du coin haut gauche du champ par rapport au coin haut gauche de la zone client de la fenêtre (équivalent à la propriété ..Y).
  • Poids faible (connu par la fonction PoidsFaible) :
    • soit la position horizontale du coin haut gauche de la fenêtre par rapport au coin haut gauche de l'écran (équivalent à la propriété ..X)
    • soit la position horizontale du coin haut gauche du champ par rapport au coin haut gauche de la zone client de la fenêtre (équivalent à la propriété ..X).
Changement de taille (WM_SIZE)
  • Poids fort (connu par la fonction PoidsFort) : Hauteur du champ ou de la fenêtre (équivalent à la propriété ..Hauteur).
  • Poids faible (connu par la fonction PoidsFaible) : Largeur du champ ou de la fenêtre (équivalent à la propriété ..Largeur).
Mode d'affichage d'une fenêtre (icônisée, maximisée, ...) sous forme d'une constante SIZE_XXX (équivalent à la fonction FenTaille).
Prise de focus (WM_SETFOCUS)Handle de la fenêtre ou du champ qui a pris le focus.
Perte de focus (WM_KILLFOCUS)Handle de la fenêtre ou du champ qui a pris le focus.

Constantes MK_XXX

Les constantes MK_XXX sont les suivantes :
MK_CONTROL8Touche Ctrl enfoncée.
MK_LBUTTON1Bouton gauche de la souris enfoncée.
MK_MBUTTON16Bouton du milieu de la souris enfoncée.
MK_RBUTTON2Bouton droit de la souris enfoncée.
MK_SHIFT4Touche Maj enfoncée

Avant d'utiliser ces constantes, il est nécessaire de saisir les lignes de code suivantes :
CONSTANTE
        MK_CONTROL=8
        MK_LBUTTON=1
        MK_MBUTTON=16
        MK_RBUTTON=2
        MK_SHIFT=4
FIN

Constantes VK_XXX

Les constantes VK_XXX sont détaillées dans le fichier "KeyConst.WL" présent dans le sous-répertoire "Personnel\Externe" du répertoire d'installation de WINDEV.
Avant d'utiliser ces constantes, il est nécessaire de saisir la ligne de code suivante :
EXTERNE "KeyConst.WL"

Constantes SB_XXX

Les constantes SB_XXX sont les suivantes :
La cage de l'ascenseur a été déplacée grâce :
SB_LINEDOWN1au bouton spin d'en bas
SB_LINEUP0au bouton spin d'en haut
SB_LINELEFT0au bouton spin à gauche
SB_LINERIGHT1au bouton spin à droite
SB_PAGEDOWN3à la barre de défilement en dessous de la cage de l'ascenseur
SB_PAGEUP2à la barre de défilement en dessus de la cage de l'ascenseur
SB_PAGELEFT2à la barre de défilement à gauche de la cage de l'ascenseur
SB_PAGERIGHT3à la barre de défilement à droite de la cage de l'ascenseur
SB_THUMBPOSITION4à la cage de l'ascenseur
SB_THUMBTRACK5à la cage de l'ascenseur

Avant d'utiliser ces constantes, il est nécessaire de saisir les lignes de code suivantes :
CONSTANTE
        SB_LINEDOWN=1
        SB_LINEUP=0
        SB_LINELEFT=0
        SB_LINERIGHT=1
        SB_PAGEDOWN=3
        SB_PAGEUP=2
        SB_PAGELEFT=2
        SB_PAGERIGHT=3
        SB_THUMBPOSITION=4
        SB_THUMBTRACK=5
FIN

Constantes SIZE_XXX

Les constantes SIZE_XXX sont les suivantes :
SIZE_RESTORED0La fenêtre est restaurée
SIZE_MINIMIZED1La fenêtre est iconisée
SIZE_MAXIMISED2La fenêtre est maximisée

Avant d'utiliser ces constantes, il est nécessaire de saisir la ligne de code suivante :
CONSTANTE
        SIZE_RESTORED=0
        SIZE_MINIMIZED=1
        SIZE_MAXIMISED=2
FIN
Exemples
L'exemple suivant permet de connaître le sens de rotation de la roulette de la souris :
// -- Traitement optionnel : Roulette de la souris
Sens est un entier
Sens = PoidsFort(_EVE.wParam)
SI Sens < 0 ALORS
        Trace("La roulette de la souris va vers le bas")
SINON
        Trace("La roulette de la souris va vers le haut")
FIN
WINDEVWindows L'exemple suivant permet d'ajouter l'icône de la fenêtre dans la barre des tâches lors de sa minimisation, et de l'enlever lors de sa maximisation.
// -- Traitement optionnel : Changement de taille
// Déclaration des constantes
CONSTANTE
SIZE_RESTORED=0
SIZE_MINIMIZED=1
SIZE_MAXIMISED=2
FIN

// Ajout de l'icône "C:\Icones\Icone.ICO" dans la barre des tâches
// lors de l'icônisation de la fenêtre
SI _EVE.wParam = SIZE_MINIMIZED ALORS
SysIconeAjoute("C:\Icones\Icone.ICO")
FIN

// Suppression de l'icône "C:\Icones\Icone.ICO"
// lors de la restauration de la fenêtre

SI _EVE.wParam = SIZE_RESTORED ALORS SysIconeSupprime()
L'exemple suivant permet de supprimer la ligne en cours dans une table lors de l'appui sur la touche Suppr :
// -- Traitement optionnel : Touche relâchée
// Intégration du fichier "KeyConst.wl" qui contient
// les constantes standard de Windows
EXTERNE "KeyConst.WL"

// Touche [Suppr] relâchée ?
SI _EVE.wParam = VK_DELETE ALORS
// Suppression de la ligne en cours ?
SI OuiNon("Supprimer la ligne en cours ?") = Oui ALORS
TableSupprime(MoiMême)
FIN
FIN
Version minimum requise
  • Version 17
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire