PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Configuration nécessaire
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Renvoie les caractéristiques d'un périphérique de téléphonie. Permet de savoir si ce périphérique supporte les appels entrants de n'importe quel type, les appels vocaux et les appels fax.
Exemple
SI ETBinaire(telCapacité("LTP2"), telOptionTypeVoix) = telOptionTypeVoix ALORS
Info("Voix gérée")
FIN

SI ETBinaire(telCapacité("LTP2"), telOptionTypeFax) = telOptionTypeFax ALORS
Info("Fax géré")
FIN
Syntaxe
<Résultat> = telCapacité(<Nom du périphérique>)
<Résultat> : Entier ou constante de type entier
  • 0 en cas d'erreur,
  • une ou plusieurs des constantes suivantes :
    telOptionTypeInconnuPériphérique acceptant les appels entrant de type inconnu.
    telOptionTypeVoixPériphérique acceptant les appels vocaux.
    Remarque : Les modems Fax autorisant la numérotation automatique peuvent renvoyer cette constante.
    telOptionTypeFaxPériphérique acceptant les appels Fax
Pour identifier simplement le résultat, utilisez la fonction ETBinaire.
<Nom du périphérique> : Chaîne de caractères
Nom du périphérique à utiliser. La liste des périphériques de téléphonie est connue avec la fonction telListePériphérique.
Remarques
WINDEVCode Utilisateur (MCU)

Configuration nécessaire

Les fonctions de téléphonie utilisent la technologie TAPI 2.0. Cette technologie est utilisable sur tous les systèmes.
Cependant, si le système utilisé est Windows NT4, il est nécessaire d'installer le service pack 4 minimum.
Remarque : La technologie TAPI 3.0 et supérieure n'est pas gérée dans cette version.
Les fonctions de téléphonie utilisent la technologie TAPI 2.0 et/ou la technologie TAPI 3.1. Ces technologies sont utilisables sur tous les systèmes.
Versions 24 et supérieures
La technologie TAPI 3.1 est désormais supportée.
Nouveauté 24
La technologie TAPI 3.1 est désormais supportée.
La technologie TAPI 3.1 est désormais supportée.
Composante : wd240com.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire