PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Configuration nécessaire
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
telAppelPasDeRéponse (Fonction)
En anglais : tapiNoAnswer
Permet de savoir si une réponse a été donnée à l'appel.
Exemple
PROCEDURE ComposerNumTel(sNuméroTel)
// On compose le numéro
SI telCompose(sNuméroTel, "EtatAppel", 4) = Vrai ALORS
// Communication établie
Message("La communication est établie")
Info("La communication est établie, vous pouvez décrocher")
RETOUR
SINON
SI PAS ErreurInfo() ~= "" ALORS
Erreur(ErreurInfo())
FIN
// On teste si la ligne est occupée
SI telAppelEstOccupé() = Vrai ALORS
Info("La ligne est occupée")
RETOUR
FIN
// On teste si le correspondant a répondu
SI telAppelPasDeRéponse() = Vrai ALORS
Info("Le correspondant n'a pas répondu")
RETOUR
FIN
FIN
Syntaxe
<Résultat> = telAppelPasDeRéponse([<Identifiant de l'appel>])
<Résultat> : Booléen
  • Vrai si le numéro appelé n'a pas eu de réponse,
  • Faux dans le cas contraire.
<Identifiant de l'appel> : Entier optionnel
Identifiant de l'appel à manipuler. Cet identifiant est connu dans la procédure WLangage appelée par la fonction telDémarreDétectionAppel. Si ce paramètre n'est pas spécifié, l'appel en cours est manipulé.
Remarques
WINDEVCode Utilisateur (MCU)

Configuration nécessaire

Les fonctions de téléphonie utilisent la technologie TAPI 2.0. Cette technologie est utilisable sur tous les systèmes.
Cependant, si le système utilisé est Windows NT4, il est nécessaire d'installer le service pack 4 minimum.
Remarque : La technologie TAPI 3.0 et supérieure n'est pas gérée dans cette version.
Les fonctions de téléphonie utilisent la technologie TAPI 2.0 et/ou la technologie TAPI 3.1. Ces technologies sont utilisables sur tous les systèmes.
Versions 24 et supérieures
La technologie TAPI 3.1 est désormais supportée.
Nouveauté 24
La technologie TAPI 3.1 est désormais supportée.
La technologie TAPI 3.1 est désormais supportée.
Composante : wd240com.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire