PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Chargement et déchargement de la DLL
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Charge en mémoire la librairie (DLL) spécifiée. Une application 32 bits peut charger une librairie 32 bits, une application 64 bits peut charger une librairie 64 bits. Cette librairie sera chargée en mémoire jusqu'à ce que :
  • l'application se termine,
  • la fonction DéchargeDLL soit exécutée.
Linux Charge en mémoire la librairie .so spécifiée.
Exemple
hInst est un entier
hInst = ChargeDLL("MaDLL.DLL")
SI hInst = 0 ALORS
        Erreur(ErreurInfo())
SINON
        Info("DLL chargée")
        DéchargeDLL(hInst)
FIN
hInst est un entier
hInst = ChargeDLL("MaDLL.DLL")
SI hInst = 0 ALORS
        Erreur("Erreur lors du chargement")
SINON
        AppelDLL32("MaDLL", "FonctionA", par1, par2)
        AppelDLL32("MaDLL", "FonctionB", par1)
        DéchargeDLL(hInst)
FIN
Syntaxe
<Résultat> = ChargeDLL(<Nom de la DLL>)
<Résultat> : Entier
  • Instance de la DLL chargée,
  • 0 en cas d'erreur. Pour plus de détails sur l'erreur, utilisez la fonction ErreurInfo.
<Nom de la DLL> : Chaîne de caractères
Nom de la librairie (DLL) à charger. Ce nom peut être complet ou relatif, mais l'extension (.DLL en général) doit être précisée.
Si ce paramètre correspond à un nom relatif, la librairie sera cherchée :
1. Dans le répertoire où est situé l'exécutable qui correspond au processus en cours.
2. Dans le répertoire en cours.
3. Dans le répertoire système de Windows. En général, "C:\Windows\System" (98) ou "C:\Winnt\System32" (NT/2000).
4. Dans le répertoire de Windows.
5. Dans les répertoires spécifiés dans le PATH.
Linux Nom de la librairie .so à charger.
Remarques

Chargement et déchargement de la DLL

La fonction AppelDLL32 charge automatiquement la DLL au besoin, puis la décharge (si elle l'a chargée). Ce mécanisme peut être très lent, sauf pour les DLL système (KERNEL, USER, GDI).
Pour optimiser la vitesse d'exécution, il est conseillé de charger une fois la DLL avec la fonction ChargeDLL puis de la décharger avec la fonction DéchargeDLL lorsque la DLL n'est plus utilisée.
Composantes
WINDEVWEBDEV - Code ServeurEtats et Requêtes wd220vm.dll
Linux wd220vm.so
Windows Mobile wp220vm.dll
Version minimum requise
  • Version 9
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire