PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
La propriété ..InterfaceModifiableAvecEtatsEtRequêtes permet de savoir si l' interface d'un état est modifiable sous le logiciel Etats & Requêtes. Dans ce cas, il n'est pas possible de supprimer un ou plusieurs champs de cet état.
Remarques :
  • Cette fonctionnalité est définie sous l'éditeur lors de la description de l'état (onglet "Options" de la fenêtre de description, options "Etat modifiable sous Etats et Requêtes" et "Interface modifiable uniquement").
  • La propriété ..ToutModifiableAvecEtatsEtRequêtes permet de savoir si un état est entièrement modifiable sous le logiciel Etats & Requêtes.
  • Pour plus de détails sur le logiciel Etats & Requêtes, consultez Logiciel Etats & Requêtes.
Versions 18 et supérieures
iPhone/iPad Cette propriété est désormais disponible pour les états dans les applications iPhone/iPad.
Nouveauté 18
iPhone/iPad Cette propriété est désormais disponible pour les états dans les applications iPhone/iPad.
iPhone/iPad Cette propriété est désormais disponible pour les états dans les applications iPhone/iPad.
Versions 21 et supérieures
Universal Windows 10 App Cette propriété est désormais disponible en mode Universal Windows 10 App.
Nouveauté 21
Universal Windows 10 App Cette propriété est désormais disponible en mode Universal Windows 10 App.
Universal Windows 10 App Cette propriété est désormais disponible en mode Universal Windows 10 App.
Exemple
// Interface de l'état modifiable sous Etats & Requêtes ?
SI MonEtat..InterfaceModifiableAvecEtatsEtRequêtes = Vrai ALORS
// Mode WINDEV ?
SI EnModeWindows() = Vrai ALORS
// Ouverture de l'état sous Etats & Requêtes
LanceEtatsEtRequêtes(MonEtat)
SINON
Info("L'interface de cet état est modifiable sous Etats & Requêtes")
FIN
SINON
Info("L'interface de cet état n'est pas modifiable sous Etats & Requêtes")
FIN
Syntaxe
<Résultat> = <Etat manipulé>..InterfaceModifiableAvecEtatsEtRequêtes
<Résultat> : Booléen
  • Vrai si l'interface de l'état spécifié est modifiable sous le logiciel Etats & Requêtes,
  • Faux dans le cas contraire.
<Etat manipulé> : Nom d'état
Nom de l'état à manipuler.
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire