PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE


  • Présentation
  • Onglet Fichiers
  • Répertoire des fichiers à utiliser en mode test
  • Informations sur le mode de gestion des fichiers
  • Ré-indexation automatique
  • Création automatique des fichiers
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Présentation
La fenêtre de description du projet permet de configurer de nombreux éléments de votre projet. Cette fenêtre est constituée des onglets suivants :
  • L'onglet "Projet" qui permet de saisir les informations générales du projet.
  • L'onglet "Analyse" qui permet d'associer une analyse au projet et / ou un modèle UML.
  • L'onglet "Fichiers" qui permet de saisir différentes informations sur les fichiers de données gérés par l'application (uniquement disponible si le projet est lié à une analyse).
  • L'onglet "Live data" qui permet de configurer l'affichage des données (provenant des fichiers de données) sous les différents éditeurs.
  • L'onglet "Langues" qui permet de paramétrer les différentes langues manipulées par le projet ainsi que les options linguistiques à utiliser pour chaque langue.
  • L'onglet "Style" qui permet de choisir le thème de gabarit, la feuille de styles personnalisée, et de personnaliser l'aperçu avant impression. Il est également possible de paramétrer la taille des écrans.
  • L'onglet "Groupe" qui permet de gérer le travail en groupe (Groupware développeur ou GDS).
  • L'onglet "Options" qui permet de configurer les options de mise à jour, de sauvegarde, de synchronisation des modèles. Cet onglet permet également d'activer le mode strict et de définir la charte de programmation.
  • L'onglet "Avancé" qui permet de gérer l'utilisation de "Etats & Requêtes", les FAA et le verrouillage de l'application.
  • L'onglet "Compilation" qui permet de configurer les options de compilation.
  • Versions 22 et supérieures
    L'onglet "Télémétrie" qui permet de configurer les options de télémétrie pour le projet.
    WEBDEV - Code Serveur Cette option n'est pas disponible.
    Nouveauté 22
    L'onglet "Télémétrie" qui permet de configurer les options de télémétrie pour le projet.
    WEBDEV - Code Serveur Cette option n'est pas disponible.
    L'onglet "Télémétrie" qui permet de configurer les options de télémétrie pour le projet.
    WEBDEV - Code Serveur Cette option n'est pas disponible.
Remarque : A partir de la version 19, HFSQL est le nouveau nom de HyperFileSQL.
Onglet Fichiers

Répertoire des fichiers à utiliser en mode test

Cette option permet de définir le répertoire des fichiers de données à utiliser en mode test : débogage, Go de fenêtre, de page ou de projet.
Par défaut, le répertoire utilisé est le répertoire de la configuration courante. Il est possible par exemple de spécifier un répertoire spécifique.
Cette option est intéressante si WINDEV est utilisé sous Windows Vista, avec l'UAC active : il est possible d'utiliser en mode test le répertoire des données de l'application.

Informations sur le mode de gestion des fichiers

Cette option permet de définir le mode de gestion des fichiers de données de l'application. Par défaut, les applications créées avec WINDEV et WEBDEV sont des applications multi-utilisateurs : les blocages sont gérés de manière automatique.

Ré-indexation automatique

La ré-indexation d'un fichier peut être rendue nécessaire par la perte ou l'altération du fichier d'index. Une ré-indexation automatique des fichiers de données peut être mise en place.
Plusieurs paramètres peuvent être fournis :
  • le nombre d'enregistrements maximum : Si le fichier de données contient moins de XXX enregistrements, la réindexation est automatique en cas d'erreur d'index. Par défaut, cette valeur vaut 100000. Si cette variable vaut 0, la ré-indexation automatique est désactivée.
  • l'affichage de la fenêtre de jauge permettant de suivre la ré-indexation en cours.
Remarque : la ré-indexation automatique est disponible uniquement sur les fichiers HFSQL Classic et HFSQL Client/Serveur.
Assistance automatique HyperFileSQL
Cette option permet d'activer la gestion automatique des erreurs par le moteur HFSQL. Pour plus de détails, consultez Gestion assistée des erreurs.
Assistance automatique HFSQL
Cette option permet d'activer la gestion automatique des erreurs par le moteur HFSQL. Pour plus de détails, consultez Gestion assistée des erreurs.

Création automatique des fichiers

Cette option permet de créer automatiquement les fichiers de données décrits dans l'analyse si ces fichiers n'existent pas lors de l'utilisation de fonctions nécessitant leur ouverture. Dans ce cas, la fonction HCréationSiInexistant est automatiquement exécutée.
Versions 23 et supérieures
Accès Natifs Cette option est prise en compte par les connecteurs natifs à SQL Server, Informix, Sybase, MySQL, MariaDB et PostgreSQL.
Nouveauté 23
Accès Natifs Cette option est prise en compte par les connecteurs natifs à SQL Server, Informix, Sybase, MySQL, MariaDB et PostgreSQL.
Accès Natifs Cette option est prise en compte par les connecteurs natifs à SQL Server, Informix, Sybase, MySQL, MariaDB et PostgreSQL.
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire