PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Menus déroulants de l'éditeur d'états
Avertissement
A partir de la version 18, cette fonctionnalité n'est plus disponible
Les tableaux ci-après indiquent les actions principales des options des menus "Insertion", "Etat", "Champ", "Code" et "Affichage" spécifiques à l'éditeur d'états.
Menu Insertion
Option Action
Nouveau champInsère le champ spécifié dans l'état
Nouvelle ruptureInsère une rupture
Nouveau blocInsère un nouveau bloc dans l'état en cours
Nouveau tableauInsère un tableau dans l'état en cours (uniquement si l'état n'a pas de tableau)
Nouvelle colonneInsère une colonne dans le tableau présent dans l'état
Nouvel état interneInsère un champ état interne dans l'état en cours
DateInsère un champ pré-défini de type date
HeureInsère un champ pré-défini de type Heure
Numéro de pageInsère un champ pré-défini correspondant au numéro de la page en cours
Nombre de pagesInsère un champ pré-défini correspondant au nombre total de pages de l'état
Numéro de page / Nombre de pagesInsère un champ pré-défini indiquant le numéro de la page en cours par rapport au nombre total de pages de l'état

Menu Etat
Option Action
DescriptionAffiche la fenêtre de description de l'état
Mise en pageAffiche la fenêtre de sélection du format de la page
Format des étiquettesAffiche la fenêtre de description du format des étiquettes (pour un état de type étiquette)
Editer la requêteAffiche la requête de base de l'état (pour un état sur requête intégrée)
Editer les trisAffiche la fenêtre de description des tris et des ruptures
Editer les conditions de sélectionAffiche la fenêtre de description des conditions de sélection
Editer les rupturesAffiche la fenêtre de description des tris et des ruptures
Editer les groupesAffiche la fenêtre de description des groupes de champs
Appliquer un gabaritPermet de sélectionner le gabarit à appliquer à l'état en cours
Champs et blocs de l'étatListe les champs et les blocs présents dans l'état

Menu Champ
Option Action
DescriptionAffiche la fenêtre de description du (des) champ(s) sélectionné(s)
Editer le textePermet de modifier le texte du champ sélectionné directement depuis l'éditeur
Choisir un stylePermet de choisir un style pour le champ sélectionné.
TableauPermet de gérer le tableau présent dans l'état
Groupes de champsAffiche la fenêtre de description des groupes de champs
AlignementPermet de gérer les options d'alignement sur les champs sélectionnés
AltitudePermet de gérer les effets de superposition des champs
GrasActive ou non le gras pour le texte du (des) champ(s) sélectionné(s)
ItaliqueActive ou non l'italique pour le texte du (des) champ(s) sélectionné(s)
SoulignéActive ou non le souligné pour le texte du (des) champ(s) sélectionné(s)
CadrePermet d'entourer le(s) champ(s) sélectionné(s) d'un cadre
Cadrer à droiteAligne le texte à droite dans le(s) champ(s) sélectionné(s)
Cadrer à gaucheAligne le texte à gauche dans le(s) champ(s) sélectionné(s)
CentrerCentre le texte dans le(s) champ(s) sélectionné(s)
JustifierJustifie le texte dans le(s) champ(s) sélectionné(s)
Adapter la tailleAdapte la taille de l'élément sélectionné à son contenu
AbonnementAffiche les caractéristiques d'abonnement du champ sélectionné

Menu Code
Option Action
Tester l'étatPermet de lancer le test de l'état en cours
Terminer le testPermet d'arrêter le test en cours
Code de l'étatAffiche les traitements associés à l'état dans une fenêtre de code
Code de la sélectionAffiche les traitements associés au champ sélectionné dans une fenêtre de code
Procédures localesAffiche les procédures locales de l'état dans le volet "Explorateur de projet" et dans le volet "Code"
Tous les codes de l'étatAffiche tous les traitements associés à l'état, à ses blocs et à ses champs
Compiler l'étatPermet de compiler l'état

Menu Affichage
Option Action
Visualiser l'état en 3DPermet de visualiser l'état en 3 dimensions
Langue affichéePermet de sélectionner la langue dans laquelle l'état est affiché sous l'éditeur
ZoomRéalise un zoom dans l'éditeur d'état selon le facteur de zoom spécifié.
Barres d'outilsParamètre les barres d'outils affichées et l'interface générale.
RègleActive ou désactive l'affichage des règles d'alignement
Grille activeActive la grille magnétique
Grille visibleRend la grille magnétique visible
OptionsConfigure l'affichage de l'état en création sous l'éditeur
Description de la sélectionAffiche la fenêtre de description du (des) champ(s) sélectionné(s)
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire