DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WEBDEV 28 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Le mot-clé MonChampHôte permet de manipuler le champ Page WEBDEV depuis le code de la page affichée dans le champ Page WEBDEV.
Les seules syntaxes autorisées sont :
  • la comparaison à la valeur NULL.
  • l'appel d'une procédure.
Exemple
// Si on est intégré dans WINDEV ou WINDEV Mobile
SI EnModePageDansFenêtre() ALORS
// Rappel de l'application WINDEV pour intégrer le choix à la facturation
MonChampHôte.DemandeFacturation(ATT_Expéditeur[gnNumLigne], ...
ATT_Résumé[gnNumLigne], gnNumLigne, ATT_CompteRendu[gnNumLigne], sNomGoodies)
FIN
Syntaxe

Vérifier si la page est utilisée par un champ Page WEBDEV

SI <Champ WEBDEV>.MonChampHôte = Null ALORS
   ...
   // La page n'est pas affichée dans un champ Page WEBDEV
   ...
FIN

SI <Champ WEBDEV>.MonChampHôte <> Null ALORS
   ...
   // La page est affichée dans un champ Page WEBDEV
   ...
FIN

Appeler une procédure de la fenêtre

MonChampHôte.NomProcédure()

Appeler une procédure de la fenêtre avec une valeur de retour

APRES MonRésultat = MonChampHôte.NomProcédure() FAIRE
// Utilisation du résultat
FIN
Remarques
  • Depuis la fenêtre WINDEV, il est possible d'appeler des procédures navigateur de la page grâce à la propriété Page.
  • Appel de procédure : Il est possible de passer des paramètres à la procédure appelée.
  • Dans la syntaxe 3 (appeler une procédure de la fenêtre avec une valeur de retour), le retour est asynchrone
Liste des exemples associés :
WW_IntégrationWEBDEVdansWINDEV Exemples didactiques (WINDEV) : WW_IntégrationWEBDEVdansWINDEV
[ + ] Cet exemple présente la fonctionnalité "WEBDEV dans WINDEV".
Il présente comment insérer un site ou une partie de site ou une page WEBDEV dans une fenêtre WINDEV avec communication bi-directionnelle en WLangage.

L'intégration d'une page WEBDEV directement dans une fenêtre WINDEV a plusieurs utilisations :
- réunir deux existants, un existant WINDEV et un existant WEBDEV,
- permettre la webisation progressive d'une application. Il suffit alors de développer les nouvelles fonctionnalités dans WEBDEV et de les intégrer dans les applications WINDEV existantes.
Version minimum requise
  • Version 28
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire