PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV Mobile 27 !
  • Permissions requises
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Liste les téléchargements du gestionnaire de téléchargement provenant de l'application en cours.
Remarque : Les fonctions de téléchargement n'auront aucun effet dans le simulateur.
Exemple
// Remplit le champ Table TABLE_Téléchargement avec la liste des téléchargements demandés
TableSupprimeTout(TABLE_Téléchargement)
 
 
ListeTéléchargement est un tableau de TéléchargementInfo = TéléchargementListe()
POUR TOUT InfoTéléchargement DE ListeTéléchargement
TableAjouteLigne(TABLE_Téléchargement, InfoTéléchargement.Identifiant, InfoTéléchargement.Titre)
FIN
 
SI TABLE_Téléchargement.Occurrence > 0 ALORS
TABLE_Téléchargement = 1
FIN
Syntaxe
<Résultat> = TéléchargementListe()
<Résultat> : Tableau de TéléchargementInfo
Tableau de variables de type TéléchargementInfo correspondant aux téléchargements provenant de l'application, présents dans le gestionnaire de téléchargement.
Remarques

Permissions requises

L'utilisation de cette fonction entraîne la modification des permissions requises par l'application.
Permission requise : INTERNET
Cette permission autorise l'application à ouvrir des sockets réseau.
Liste des exemples associés :
Android Téléchargements Android (WINDEV Mobile) : Android Téléchargements
[ + ] Cet exemple illustre l'usage du téléchargement en arrière-plan disponible dans WINDEV Mobile et Android.
Il n'est donc plus nécessaire de conserver l'application ouverte pour proposer le téléchargement d'un fichier. Le gestionnaire de téléchargement permet de télécharger des fichiers volumineux et permet également de notifier l'application lors de la fin des téléchargements.
Composante : wd270android.aar
Version minimum requise
  • Version 27
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire