PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Création d'une fenêtre
  • Création de fenêtres vierges
  • Fenêtre interne
  • Fenêtre basée sur un modèle
  • Manipulations simples sur une fenêtre depuis l'éditeur
  • Principales caractéristiques d'une fenêtre
  • Caractéristiques
  • Fenêtre de description
  • Affichage des caractéristiques
  • Caractéristiques par onglet
  • Fenêtre et image
  • Présentation
  • Configuration de l'image de fond
  • Fenêtre détourée
  • Ouvrir une fenêtre "popup"
  • Présentation
  • Grisage automatique des fenêtres
  • Fenêtre interne
  • Modèles de fenêtre
  • Traitements associés aux fenêtres
  • Traitements gérés par défaut
  • Traitements optionnels
  • Les menus contextuels
  • Fenêtres d'édition des menus contextuels
  • Fonctionnalités disponibles
  • Menu contextuel système par défaut
  • Les menus principaux
  • Présentation
  • Vocabulaire associé aux menus principaux
  • Fonctionnalités disponibles
  • Les options de menus
  • Présentation
  • Manipuler les options de menu sous l'éditeur
  • Manipuler les options de menu par programmation
  • La barre de message
  • Fenêtre de description d'une barre de message
  • Type d'une case de la barre de message
  • Caractéristiques d'une case de la barre de message
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
8. Les fenêtres en pratique
Chapitre précédentSommaireChapitre suivant
Une fenêtre a pour but d'afficher, de consulter et de saisir des informations. Ces informations peuvent provenir de fichiers de données d'une analyse, de fichiers externes, de requêtes, ...
WINDEV propose plusieurs solutions pour créer les fenêtres d'un projet :
  • Créer une fenêtre vierge avec l'assistant.
  • Construire l'ensemble des fenêtres de l'application à partir de la description de l'analyse.
  • Créer une fenêtre à partir de la description de l'analyse (avec son code ou non).
  • Créer des fenêtres standard.
  • Créer des fenêtres basées sur un modèle, ...
Quelle que soit la méthode utilisée, la fenêtre pourra être modifiée après sa création : il sera possible d'ajouter, modifier ou supprimer des champs, de modifier les caractéristiques de la fenêtre.
Pour plus de détails sur la manipulation des champs d'une fenêtre, consultez Les champs en pratique.
Ce chapitre traite les sujets suivants :
Création d'une fenêtre
WINDEV permet de créer plusieurs types de fenêtres :
  • Fenêtres vierges, sans aucun champ.
  • Fenêtres créées par le RAD / RID.
  • Fenêtres internes. Ces fenêtres pourront être utilisées dans des champs de type "Fenêtre Interne".
  • Fenêtres basées sur un modèle de fenêtres.
  • Fenêtres importées à partir d'une application non WINDEV.
Ce paragraphe détaille uniquement la création de fenêtres vierges, internes ou basées sur un modèle. Pour plus de détails, consultez l'aide en ligne.

Création de fenêtres vierges

Pour créer une fenêtre vierge :
  1. Cliquez sur parmi les boutons d'accès rapide. La fenêtre de création d'un nouvel élément s'affiche : cliquez sur "Fenêtre" puis sur "Fenêtre". L'assistant de création d'une fenêtre se lance.
  2. Choisissez le type "Vierge".
  3. Spécifiez le gabarit de la fenêtre.
  4. Validez la création de la fenêtre. Une fenêtre vierge est créée sous l'éditeur. La fenêtre de sauvegarde apparaît automatiquement.
  5. Spécifiez le titre et le nom de la fenêtre. La fenêtre correspond à un fichier ".WDW". Par défaut, ce fichier sera créé dans le répertoire principal du projet. Ce nom sera utilisé pour manipuler la fenêtre.
  6. Validez l'enregistrement de la fenêtre.
  7. Créez les champs dans la fenêtre.
Remarque : Les principales caractéristiques des fenêtres sont détaillées dans l'aide en ligne. Les différents types de champs sont présentés dans le chapitre Les champs en pratique.

Fenêtre interne

Une fenêtre interne est une fenêtre sans barre de titre, ni barre de message qui sera directement incluse dans les autres fenêtres de votre application grâce au champ "Fenêtre interne".
Ainsi, il est possible d'inclure une fenêtre (et son code) dans une autre fenêtre.
Pour créer une fenêtre interne :
  1. Cliquez sur parmi les boutons d'accès rapide. La fenêtre de création d'un nouvel élément s'affiche : cliquez sur "Fenêtre" puis sur "Fenêtre". L'assistant de création d'une fenêtre se lance.
  2. Sélectionnez l'onglet "Fenêtre interne".
  3. Sélectionnez le type de fenêtre et le gabarit associé.
  4. Validez. La fenêtre de sauvegarde apparaît automatiquement.

Fenêtre basée sur un modèle

WINDEV permet également de créer une fenêtre basée sur un modèle de fenêtres. Dans ce cas, il suffit de sélectionner le modèle de fenêtres voulu. Les modèles de fenêtres contiennent tous les éléments graphiques et le code communs à l'ensemble des fenêtres de votre application.
Pour créer une fenêtre basée sur un modèle :
  1. Cliquez sur parmi les boutons d'accès rapide. La fenêtre de création d'un nouvel élément s'affiche : cliquez sur "Fenêtre" puis sur "Fenêtre". L'assistant de création d'une fenêtre se lance.
  2. Sélectionnez l'onglet "Basée sur un modèle".
  3. Sélectionnez le modèle voulu et le gabarit associé.
  4. Validez. La fenêtre de sauvegarde apparaît automatiquement.
Les modifications effectuées dans un modèle de fenêtres sont automatiquement reportées sur toutes les fenêtres utilisant ce modèle.
Un modèle de fenêtres permet de respecter la charte graphique définie pour une application.
Manipulations simples sur une fenêtre depuis l'éditeur
L'éditeur de fenêtres permet de réaliser les manipulations suivantes sur les fenêtres :
  • Ouvrir une fenêtre sous l'éditeur : Il suffit de double-cliquer sur le nom de la fenêtre affiché dans le volet "Explorateur de projet".
  • Modifier la taille d'une fenêtre.
  • Sauvegarder et copier une fenêtre.
  • Importer et exporter une fenêtre.
  • Modifier l'ordre de navigation.
Pour plus de détails sur ces manipulations, consultez l'aide en ligne.
Principales caractéristiques d'une fenêtre

Caractéristiques

Une fenêtre peut accueillir tous les types de champs disponibles. Une fenêtre peut :
  • être redimensionnable : l'utilisateur pourra agrandir ou diminuer la taille de la fenêtre. Selon les caractéristiques d'ancrage définies pour chacun des champs, la position des champs dans la fenêtre pourra varier lors de ce redimensionnement (pour plus de détails sur l'ancrage, consultez Les champs en pratique).
  • avoir une image de fond : cette image est affichée en fond de la fenêtre et les champs viennent se superposer à cette image. Il est également possible de définir des caractéristiques de redimensionnement grâce au mode 9 images. Pour plus de détails, consultez Fenêtre et image.
  • être détourée : la fenêtre aura ainsi une forme originale (fenêtre en forme de cercle, d'ordinateur, ...). Pour plus de détails, consultez le paragraphe Fenêtre détourée.
  • avoir un menu déroulant : ce menu permettra aux utilisateurs d'accéder plus rapidement aux principales fonctionnalités de l'application. Pour créer un menu déroulant dans une fenêtre, sous le volet "Fenêtres", dans le groupe "Barres et menus", déroulez "Menu principal" et sélectionnez l'option "Ajouter le menu principal". La première option apparaît dans la fenêtre. Les options peuvent être manipulées grâce au menu contextuel des options. Les options de menu peuvent ensuite être manipulées par programmation. Pour plus de détails, consultez Les menus.
  • avoir une barre de message : cette barre de message affichera les messages d'aide associés aux différents champs de la fenêtre. Cette barre de message permet également d'afficher des informations supplémentaires. Pour plus de détails, consultez La barre de message.
  • être multilingue : toutes les langues définies pour la fenêtre seront disponibles pour tous les champs de la fenêtre. Une fenêtre peut être associée à plus de langues que le projet (cas par exemple des fenêtres partagées entre plusieurs projets). Pour plus de détails, consultez le chapitre Applications multilingues.
  • se griser automatiquement si elle devient inaccessible. Cette fonctionnalité s'appelle GFI pour Grisage des Fenêtres Inaccessibles. Pour plus de détails, consultez le paragraphe Grisage automatique des fenêtres.
  • autoriser le drag and drop. Pour plus de détails sur le drag and drop et sa programmation, consultez l'aide en ligne.
  • autoriser la modification de l'interface par l'utilisateur final. Pour plus de détails, consultez l'aide en ligne.
Remarque : Pour forcer une action sur une fenêtre, il suffit de définir un bouton de cette fenêtre en mode "Exécution automatique". Pour plus de détails, consultez le paragraphe Les champs en pratique.

Fenêtre de description

La fenêtre de description est une fenêtre à onglets, regroupant toutes les caractéristiques paramétrables de la fenêtre.
Remarque : Il est également possible de visualiser et/ou de modifier les caractéristiques d'une fenêtre dans le modifieur. Pour plus de détails, consultez l'aide en ligne.

Affichage des caractéristiques

Pour afficher la fenêtre de description :
  • soit double-cliquez sur le fond de la fenêtre.
  • soit sélectionnez l'option "Description" du menu contextuel de la fenêtre (clic droit de la souris).
  • soit sélectionnez la fenêtre et utilisez le raccourci clavier Alt + Entrée.

Caractéristiques par onglet

Ce paragraphe présente rapidement les différentes catégories de caractéristiques affichées par onglet. Pour plus de détails sur chacune des caractéristiques présentes dans les différents onglets, consultez l'aide en ligne.
Onglet Général
L'onglet "Général" permet de spécifier le nom de la fenêtre et son titre.
Onglet IHM
L'onglet "IHM" permet de définir les différents paramètres de l'interface de la fenêtre :
  • visibilité de la fenêtre,
  • position de la fenêtre,
  • gestion du clic droit, du curseur de la souris,
  • association à un menu contextuel, ...
Onglet Détail
L'onglet "Détail" permet de définir les différents paramètres de la fenêtre :
  • modification de l'interface par l'utilisateur final,
  • animation,
  • fermeture automatique.
Onglet Image
Cet onglet permet de paramétrer :
  • l'image de fond de la fenêtre,
  • l'image de la poignée de redimensionnement,
  • l'icône de la fenêtre.
Onglet Langues
Cet onglet permet de connaître les langues gérées par la fenêtre, ainsi que la langue affichée sous l'éditeur. Il est possible d'ajouter, de modifier ou de supprimer des langues.
Onglet Notes
L'onglet "Notes" permet de décrire le fonctionnement détaillé de la fenêtre. Ces informations seront imprimées dans les dossiers de programmation (dossier du projet, dossier de la fenêtre, ...).
Onglet Aide
L'onglet "Aide" permet d'associer un fichier d'aide contextuelle à la fenêtre. Ce fichier d'aide contient les pages d'aide contextuelle affichées par chaque champ.
Onglet Style
L'onglet "Style" permet de définir le style de la fenêtre :
  • Présence de la barre de titre.
  • Présence des différentes icônes.
  • Présence de la barre de message, ...
Fenêtre et image

Présentation

Pour optimiser le look de vos écrans, WINDEV permet d'utiliser :
  • des couleurs de fond. De nombreuses couleurs standard peuvent être utilisées. La couleur de fond est configurée dans l'onglet "Style" de la fenêtre de description de la fenêtre.
  • des images dans vos fenêtres. Ces images sont utilisées en image de fond de la fenêtre. Vos champs sont superposés sur cette image. La configuration de l'image de fond est réalisée dans l'onglet "Image" de la fenêtre.
Remarques :
  • Si nécessaire, WINDEV offre également la possibilité d'utiliser le look et le thème XP/Vista dans vos fenêtres. Pour plus de détails, consultez l'aide en ligne.
  • Pour personnaliser vos fenêtres, vous pouvez également utiliser un gabarit ou un modèle de fenêtres.

Configuration de l'image de fond

La configuration est effectuée dans l'onglet "Image" de la description de la fenêtre.
Vous pouvez sélectionner directement le fichier correspondant à l'image de fond ou sélectionner une image du catalogue. Les principaux formats d'image pouvant être affichés sont les suivants : BMP, JPEG, TIFF ou GIF.
Il est également possible de réaliser directement un Drag and Drop du fichier image présent dans l'explorateur vers la fenêtre WINDEV.
Les options possibles sur l'image sont :
  • Gestion des images multilingues.
  • Mode d'affichage.
  • Position.
  • Transparence.
  • Symétrie.
  • Mode 9 images.
  • Détourage de la fenêtre selon l'image de fond.
Gestion des images multilingues
Une image de fond différente peut être affichée selon la langue d'exécution du programme. Les caractéristiques d'affichage peuvent être spécifiques à chaque langue.
Pour définir une image de fond multilingue :
  1. Cliquez sur l'icône présente à droite du nom de l'image de fond.
  2. Sélectionnez l'option "Multi-langues".
  3. Pour chaque langue définie dans votre fenêtre, choisissez l'image appropriée.
  4. Validez. Le libellé "Valeur multilangue" apparaît dans le champ de définition des images de fond.
Mode d'affichage
Une image peut être affichée dans une fenêtre selon plusieurs modes d'affichage. Ces modes d'affichage permettent d'obtenir différents effets :
  • 100% : l'image est affichée à 100% à partir du coin haut gauche du champ Image.
  • Centré : l'image est affichée à 100% et centrée dans le champ Image.
  • Etiré : l'image est déformée pour occuper tout l'espace du champ Image.
  • Répété : l'image est affichée à 100% et répétée dans le champ Image pour occuper tout l'espace du champ.
  • Homothétique : l'image est agrandie proportionnellement pour être affichée entièrement dans le champ Image.
  • Homothétique étendu : l'image est proportionnellement agrandie pour que le plus petit côté de l'image soit affiché entièrement dans le champ Image.
  • Homothétique centré : l'image est homothétique et centrée dans le champ Image.
  • Homothétique centré étendu : l'image est étendue et centrée dans le champ Image.
  • Homothétique sans agrandissement : si l'image peut être affichée entièrement dans la fenêtre, elle est affichée à 100%. Si l'image est plus grande que la fenêtre, elle est automatiquement réduite proportionnellement pour être affichée entièrement.
  • Homothétique centré sans agrandissement : l'image est centrée et homothétique sans agrandissement.
L'option "Affichage Haute Qualité" permet en mode homothétique d'améliorer la qualité de l'image lorsque celle-ci est réduite par rapport à sa taille initiale.
Position
Ce paramètre permet de définir la position du point haut gauche de l'image par rapport à la surface de la fenêtre.
Ces options seront conservées même si l'image est modifiée par programmation (propriété ..Image).
Transparence
Les options de transparence de l'image de fond sont les suivantes :
  • Magenta transparent : Le magenta présent dans l'image sera transparent à l'affichage sous l'éditeur comme en exécution.
Transparence : aucuneMagenta transparent

  • Point haut gauche : tous les points ayant la même couleur que celle du point haut gauche de l'image seront transparents.
Ces options seront conservées même si l'image est modifiée par programmation (propriété ..Image).
Symétrie
Les options de symétrie permettent de changer l'orientation de l'image contenue dans le fichier image. Ces options seront conservées même si l'image est modifiée par programmation (propriété ..Image).
Image originale :
Symétrie
verticale
Symétrie
horizontale
Symétrie
horizontale
et verticale
XXXIMAGEXXX

Mode 9 images
Si cette option est sélectionnée, le mode 9 images sera utilisé sur l'image de fond de la fenêtre.
Le mode 9 images consiste à découper l'image de fond en 9 zones.
Pour chaque zone, il est possible de définir si la partie de l'image correspondant à la zone doit être affichée ou non (il suffit de cocher le nom de la zone pour l'afficher). Si la partie de l'image n'est pas affichée, elle sera remplacée par la couleur de fond de la fenêtre.
Les marges permettent de définir la taille de chaque zone.
Lors du redimensionnement de la fenêtre, seules les zones 2, 4, 6, 8 et 5 changent de taille pour occuper tout l'espace :
Le mode 9 images permet de gérer le fonctionnement de chaque zone lors du redimensionnement de la fenêtre.
Pour chaque zone :
  • soit en répétant l'image qui compose la zone,
  • soit en étirant l'image qui compose la zone.

Fenêtre détourée

WINDEV permet de détourer les fenêtres. Les fenêtres auront ainsi des formes originales (fenêtre en forme de cercle, d'ordinateur, ...).
La forme de la fenêtre est définie par une image. Dans cette image, utilisez une couleur spécifique pour définir les zones transparentes de l'image (par exemple, la couleur "Magenta Clair"). Toutes ces zones seront invisibles lors de l'affichage de la fenêtre en exécution : la fenêtre sera alors détourée.
Attention : Les bordures de cette image doivent être les plus nettes possible (pas de dégradé, ...) afin de ne pas obtenir d'effets d'affichage lors de l'aperçu ou de l'ouverture de la fenêtre détourée. La configuration du détourage de la fenêtre est effectuée dans l'onglet "Image" de la fenêtre de description de la fenêtre.
Ouvrir une fenêtre "popup"

Présentation

WINDEV permet d'ouvrir des fenêtres de type "popup".
Une fenêtre "popup" correspond à une fenêtre de taille réduite s'ouvrant au-dessus de la fenêtre en cours. Généralement, cette fenêtre permet à l'utilisateur de réaliser une sélection. Cette fenêtre renvoie donc à la fenêtre principale la valeur sélectionnée par l'utilisateur. Cette fenêtre se ferme automatiquement dès qu'un clic gauche de souris est effectué (à l'intérieur ou non de la fenêtre popup).
Par exemple :
Remarque : Les caractéristiques d'une fenêtre popup sont les suivantes :
  • ouverture par défaut sous le champ qui ouvre la fenêtre (ou au-dessus ou à gauche du champ si la place disponible sous le champ est insuffisante).
    La position d'ouverture peut être modifiée par programmation.
  • fermeture automatique dès que la fenêtre n'a plus le focus ou dès l'appel de la fonction Ferme.
  • seule l'icône de fermeture apparaît dans la barre de titre de la fenêtre (si la barre de titre a été définie dans le style).
Grisage automatique des fenêtres
Votre application ouvre plusieurs fenêtres simultanément et vous ne savez plus quelle fenêtre est celle à utiliser ?
La ou les fenêtres inactives peuvent se griser automatiquement. Ainsi, vous devinez instinctivement la fenêtre à utiliser.
Cette fonctionnalité s'appelle GFI pour Grisage des Fenêtres Inaccessibles.
Par exemple :
Etape 1 : Vous modifiez des informations concernant un client puis vous cliquez sur le bouton "Valider".
Etape 2 : Une fenêtre vous demande de confirmer ou d'annuler ces modifications. La fenêtre principale (en arrière-plan) est devenue inaccessible. Elle s'est grisée automatiquement. Vous savez immédiatement quelle fenêtre doit être utilisée.
Les fonctionnalités du GFI sont disponibles au niveau du projet ou personnalisables au niveau de chaque fenêtre.
Il est également possible d'agir sur le GFI par programmation.
Pour plus de détails, consultez l'aide en ligne.
Fenêtre interne
Les fenêtres internes permettent de partager dynamiquement une même partie d'interface au sein d'une ou de plusieurs applications.
L'interface à utiliser plusieurs fois est créée dans une fenêtre de type "Fenêtre Interne".
Cette interface est utilisée dans les différentes fenêtres de votre application grâce au champ de type "Fenêtre interne".
Remarque : La fenêtre à fusionner peut être issue d'un composant.
Pour plus de détails, consultez l'aide en ligne.
Modèles de fenêtre
WINDEV permet de créer des modèles de fenêtres. Ces modèles contiennent tous les éléments graphiques et le code communs à l'ensemble des fenêtres de votre application.
Les modifications effectuées dans un modèle de fenêtres sont automatiquement reportées sur toutes les fenêtres utilisant ce modèle.
Un modèle de fenêtres permet de respecter la charte graphique définie pour une application.
L'utilisation de modèles de fenêtres dans vos applications permet de :
  • simplifier la création des fenêtres de l'application.
  • simplifier la mise en page des fenêtres de l'application.
  • simplifier la mise à jour de la charte graphique de l'application.
Un modèle de fenêtres se crée aussi simplement qu'une fenêtre. Pour créer une fenêtre en utilisant un modèle, il suffit de choisir l'option "basée sur un modèle".
Par défaut, toute modification effectuée dans le modèle est reportée dans les fenêtres l'utilisant. Il est cependant possible dans une fenêtre spécifique de gérer des cas particuliers en surchargeant les éléments du modèle.
Pour plus de détails, consultez l'aide en ligne.
Traitements associés aux fenêtres

Traitements gérés par défaut

WINDEV gère par défaut les traitements suivants (ordre d'apparition sous l'éditeur de code) :
  • Déclarations globales :
    Déclaration des variables globales à la fenêtre
  • Fin d'initialisation :
    Exécuté lors de l'ouverture de la fenêtre, avant le code de prise de focus. Le traitement d'initialisation des champs de la fenêtre est exécuté après ce code.
  • Fermeture :
    Exécuté lors de la fermeture de la fenêtre. Remarque : une reprise de saisie sur un des champs de la fenêtre dans ce code empêche la fenêtre de se fermer.
  • Demande de mise à jour de l'affichage :
    Permet de regrouper le code de mise à jour des champs de la fenêtre : contenu des champs, état (visible, grisé, ...), libellé à mettre à jour, ...
    Ce traitement est lancé sur demande grâce aux fonctions :
  • Affectation de la propriété ..Valeur (fenêtre interne uniquement)
    Exécuté lors de l'utilisation de la propriété ..Valeur en affectation sur le champ Fenêtre Interne.
  • Récupération de la propriété ..Valeur (fenêtre interne uniquement)
    Exécuté lors de l'utilisation de la propriété ..Valeur en lecture sur le champ Fenêtre Interne.

Traitements optionnels

Plusieurs traitements optionnels peuvent être gérés. Il suffit de :
  1. Cliquer sur les "..." présents dans le traitement "Autres traitements" de l'éditeur de code.
  2. La fenêtre des traitements optionnels s'affiche.
  3. Sélectionner le ou les traitements optionnels à ajouter et valider.
  4. Les traitements sélectionnés sont automatiquement ajoutés à la suite des traitements proposés par défaut.
Il est ainsi possible de gérer par exemple :
  • la prise et la perte de focus,
  • la modification d'un des champs de la fenêtre,
  • la modification de la taille de la fenêtre,
  • le survol de la fenêtre par la souris,
  • le bouton gauche enfoncé, relâché, avec double-clic,
  • le bouton droit enfoncé, relâché, avec double-clic,
  • la roulette de la souris, ...
Les menus contextuels
Un menu contextuel peut être ouvert par l'utilisateur grâce à un clic droit de la souris. Ce menu permet aux utilisateurs d'accéder plus facilement aux fonctionnalités spécifiques d'un champ d'une fenêtre ou d'une fenêtre.
WINDEV permet de gérer deux types de menu contextuel :
  • les menus contextuels système gérés par Windows. Ces menus contextuels s'affichent lors d'un clic droit sur certains types de champs (champ de saisie, table, ...). Pour plus de détails, consultez le paragraphe Menu contextuel système par défaut.
  • les menus contextuels personnalisés gérés par WINDEV. Ces menus sont créés sous l'éditeur de fenêtres et peuvent être manipulés par programmation.
WINDEV permet de créer des menus contextuels personnalisés et d'associer ces menus contextuels :
  • soit à un ou plusieurs champs d'une fenêtre.
  • soit à une fenêtre.
Par exemple :

Fenêtres d'édition des menus contextuels

WINDEV permet de créer et de modifier des menus contextuels personnalisés dans une fenêtre d'édition particulière. Pour mieux comprendre la gestion des menus contextuels personnalisés, voici le vocabulaire lié à cette fenêtre d'édition :

Fonctionnalités disponibles

WINDEV permet de :
  • Créer un menu contextuel personnalisé.
  • Associer un menu contextuel personnalisé existant à un ou plusieurs éléments (fenêtre ou champs).
  • Editer un menu contextuel personnalisé.
  • Afficher la fenêtre de description d'un menu contextuel personnalisé.
  • Supprimer un menu contextuel personnalisé.
Pour plus de détails, consultez l'aide en ligne.

Menu contextuel système par défaut

Les types de champ suivants ont un menu contextuel système par défaut (affiché si aucun menu contextuel personnalisé n'est associé au champ) :
  • un champ de saisie :
Pour plus de détails sur la traduction de ce menu, consultez l'aide en ligne.
  • une colonne de table :
Pour plus de détails sur la traduction de ce menu, consultez l'aide en ligne.
  • un champ ActiveX :
Remarque : Le menu contextuel système affiché dépend de l'ActiveX associé au champ.
un champ HTML :
Remarque : Le menu contextuel système affiché est celui d'Internet Explorer. Il dépend de l'objet sélectionné dans la page (image, texte, lien, ...).
Ce menu contextuel par défaut peut être désactivé aussi bien depuis l'éditeur que par programmation.
Les menus principaux

Présentation

Un menu principal est obligatoirement associé à une fenêtre. Ce menu est affiché sous la barre de titre de la fenêtre sous WINDEV. En règle générale, les applications contiennent une fenêtre menu. Cette fenêtre contient uniquement un menu principal et permet d'accéder aux autres fenêtres de l'application.
Par exemple :

Vocabulaire associé aux menus principaux

Pour manipuler simplement un menu principal, il est nécessaire de connaître le vocabulaire suivant :

Fonctionnalités disponibles

WINDEV permet de :
  • Créer un menu principal.
  • Editer un menu principal.
  • Supprimer un menu principal.
Pour plus de détails, consultez l'aide en ligne.
Cas particulier : Menu utilitaire
WINDEV permet d'insérer automatiquement un menu "utilitaire" (de type "?") dans votre application. Sous le volet "Fenêtre", dans le groupe "Barres et menus", déroulez "Menu principal" et sélectionnez l'option "Ajouter le menu "?".
Les options de menus

Présentation

Un menu (contextuel personnalisé ou principal) est composé d'une ou de plusieurs options et sous-options. Chaque option permet d'exécuter un code WLangage.
Les manipulations des options de menu sous l'éditeur sont identiques que le menu soit un menu principal ou un menu contextuel personnalisé.
Pour manipuler les options de menu, il suffit d'éditer le menu concerné.
Pour éditer (ou afficher sous l'éditeur) :
  • le menu principal d'une fenêtre :
    • ouvrez la fenêtre concernée sous WINDEV.
    • sélectionnez une des options de menu. Les options et les sous-options s'affichent automatiquement.
  • un menu contextuel personnalisé d'une fenêtre : sous le volet "Fenêtre", dans le groupe "Barres et menus", déroulez "Menus contextuels" et sélectionnez l'option "<NomMenuContextuel>".

Manipuler les options de menu sous l'éditeur

L'éditeur de fenêtres permet de réaliser très simplement les manipulations suivantes :
  • Ajouter une option de menu.
  • Ajouter un séparateur.
  • Ajouter un sous-menu.
  • Supprimer une option de menu.
Les options de menu peuvent également être directement manipulées sous l'éditeur de fenêtres et leurs caractéristiques sont modifiables grâce à une fenêtre de description.
La fenêtre de description des options de menu permet par exemple de :
  • modifier le libellé de l'option.
  • cocher ou décocher une option de menu.
  • associer une image à une option de menu.
  • associer un raccourci clavier à une option de menu.
Il est également possible d'associer du code WLangage à une option de menu. Seules les options de menu ne possédant pas de sous-menu peuvent lancer un traitement WLangage.
Pour plus de détails, consultez l'aide en ligne.

Manipuler les options de menu par programmation

La manipulation d'une option de menu est identique que le menu soit un menu contextuel ou un menu principal.
Pour manipuler par programmation une option de menu, utilisez la notation :
  • "<NomOption>" si l'option de menu est manipulée depuis la fenêtre.
  • "<NomFenêtre>.<NomMenu>.<NomOption>" si l'option est manipulée depuis une autre fenêtre.
La barre de message
Il est possible d'afficher dans la barre de message d'une fenêtre :
  • un message d'information lié au champ en cours. Ce message est saisi dans l'onglet "Aide" de la fenêtre de description du champ.
    Le message sera affiché dans la barre de message lorsque l'utilisateur sélectionnera le champ.
  • un message d'information spécifique. Ce message est affiché par programmation grâce à la fonction Message.
  • une jauge de progression. Cette jauge est affichée par programmation grâce à la fonction Jauge.
Pour afficher simultanément diverses informations, il est possible de diviser la barre de message en plusieurs cases (option "Insérer une case" dans le menu contextuel de la barre de message).

Fenêtre de description d'une barre de message

La fenêtre de description d'une barre de message permet de :
  • ajouter et/ou supprimer des cases.
  • modifier l'ordre des cases.
  • spécifier pour chaque case les informations à afficher.
Pour plus de détails, consultez l'aide en ligne.

Type d'une case de la barre de message

Le type de la case permet d'afficher :
  • La jauge de progression. Cette jauge sera exécutée lors de l'utilisation de la fonction Jauge.
  • Le message d'aide associé au champ ayant le focus. Ce message d'aide est défini dans l'onglet "Aide" du champ ou par programmation grâce à la propriété ..Message.
  • La date du poste en cours.
  • L'heure du poste en cours.
  • La position du curseur dans le champ de saisie en cours (option Colonne et Ligne du Caret).
  • L'état de la touche Maj, indiquant si la touche de verrouillage des majuscules est activée ou non.
  • L'état de la touche [INSER], indiquant si la touche [Inser] est activée ou non.
  • Le nom de l'utilisateur actuel dans une application utilisant le groupware utilisateur.
Deux options spécifiques sont également disponibles :
  • Par programmation : Les informations affichées dans la barre de message sont spécifiées par programmation (fonction Message par exemple).
  • Traitement de mise à jour : Le traitement "A chaque mise à jour" est automatiquement associé à la case de la barre de message. Ce traitement est alors exécuté régulièrement. Ce traitement peut par exemple contenir les éléments à afficher dans la case.

Caractéristiques d'une case de la barre de message

La fenêtre de description de la barre de message permet également de définir les différentes caractéristiques d'affichage des cases de la barre de message.
  • La position de la case dans la barre de message.
  • L'image de fond de la case.
  • La couleur de fond de la case.
  • La largeur de la case.
  • Si la case est en saisie.
  • L'ancrage de la case (son fonctionnement lors du redimensionnement de la fenêtre).
Toutes ces caractéristiques peuvent être manipulées par programmation grâce aux propriétés disponibles sur les cases des barres de message.
Chapitre précédentSommaireChapitre suivant
Version minimum requise
  • Version 9
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire