PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Présentation
  • Visualiser et modifier la description d'un état
  • Présentation
  • Gestion de la source de données
  • Options d'affichage dans l'aperçu avant impression
  • Gestion des blocs
  • Format
  • Options
  • Formulaire et image de fond
  • Langue
  • Ouvrir, fermer et enregistrer un état
  • Ouvrir un état
  • Fermer un état
  • Enregistrer un état
  • Récupération automatique
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Manipuler un état (sous l'éditeur)
Présentation
Après la création d'un état, il est possible à tout moment de modifier toute la description de cet état :
  • source de données,
  • champs présents dans l'état,
  • mise en page, ...
Seul le type de l'état n'est pas modifiable. En effet, trop de paramètres spécifiques sont mis en jeu. Pour changer le type de l'état, il suffit de créer un nouvel état.
Cette page d'aide présente :
Visualiser et modifier la description d'un état

Présentation

Les principales options de l'état sont accessibles dans la description de l'état (option "Description de l'état" du menu contextuel). Pour plus de détails sur chacune des options des différents onglets, consultez l'aide contextuelle de la fenêtre de description (icône Aide contextuelle).
Voici une présentation rapide des différents onglets de la description de l'état.
Remarque : Les principales options de l'état sont également accessibles via le volet "Modifieur".

Gestion de la source de données

A tout moment, il est possible de paramétrer et de modifier la source de données d'un état. Ces manipulations se font principalement à partir de la fenêtre de description de l'état.
Il est possible de :
  • modifier la source de données de l'état (onglet "Données" de la description de l'état) :
    • soit en changeant le type de la source d'alimentation de l'état (passer par exemple d'un état sur requête à un état sur fichier de données ou sur une zone mémoire).
    • soit en changeant les paramètres de la source de données sélectionnée (modification de la requête, modification du tri, mise en place de bornes de parcours, ...).
  • paramétrer le fonctionnement de l'état si la source de données est vide (onglet "Détail" de la description de l'état). En effet, si la source de données est vide, l'éditeur d'états offre la possibilité soit d'imprimer l'état, soit d'afficher un message d'avertissement sans imprimer l'état. Le message d'avertissement est paramétrable.paramétrer le fonctionnement de l'état si la source de données est vide (onglet "IHM" de la description de l'état). En effet, si la source de données est vide, l'éditeur d'états offre la possibilité soit d'imprimer l'état, soit d'afficher un message d'avertissement sans imprimer l'état. Le message d'avertissement est paramétrable.
Remarque : Si l'état est basé sur une requête, l'option "Editer la requête" du menu contextuel permet d'éditer directement la requête dans l'éditeur de requêtes. Il est alors possible de modifier cette requête.

Options d'affichage dans l'aperçu avant impression

Le paramétrage des options d'affichage dans l'aperçu avant impression est réalisé dans l'onglet "Détail" de la description de l'état. Il est possible de :
  • spécifier les formats d'exports proposés par l'aperçu avant impression. Les formats cochés seront disponibles pour l'utilisateur.
  • paramétrer le message affiché si la source de données est vide.
  • spécifier si l'état est modifiable sous le logiciel "Etats et requêtes" et sous quelles conditions. Pour plus de détails, consultez Logiciel Etats & Requêtes.
  • spécifier si le code compilé doit être intégré. Cette option est nécessaire dans des cas très rares.
  • spécifier si il est nécessaire de tenir compte des espaces qui complètent les rubriques. Cette option concerne uniquement les champs auto-extensibles associés à une rubrique texte complétée par des espaces.
  • spécifier si l'impression doit être effectuée page après page. Dans ce cas, l'impression est envoyée au spooler d'impression après chaque page imprimée.
  • spécifier si la première page est une page de couverture. Dans ce cas, la première page sera affichée à droite dans l'aperçu (en mode d'affichage par pages doubles).
Le paramétrage des options d'affichage dans l'aperçu avant impression est réalisé dans l'onglet "IHM" de la description de l'état. Il est possible de :
  • spécifier les formats d'exports proposés par l'aperçu avant impression. Les formats cochés seront disponibles pour l'utilisateur.
  • paramétrer le message affiché si la source de données est vide.
  • Versions 19 et supérieures
    paramétrer le message affiché lors de la sélection et du tri des enregistrements.
    Nouveauté 19
    paramétrer le message affiché lors de la sélection et du tri des enregistrements.
    paramétrer le message affiché lors de la sélection et du tri des enregistrements.

Gestion des blocs

La gestion des blocs d'un état peut aussi bien être réalisée dans l'état en édition que dans la fenêtre de description de l'état.
La gestion des blocs peut être réalisée :
  • soit directement depuis les différentes options du menu contextuel des blocs (clic droit sur l'intitulé des blocs).
  • soit grâce à la fenêtre de description de l'état (option "Description de l'état" du menu contextuel), onglet "Blocs".
Pour plus de détails sur la gestion des blocs, consultez Blocs d'un état.

Format

L'onglet "Format" de la fenêtre de description de l'état permet de configurer :
  • le format de la page (ou de la planche d'étiquettes).
  • le retrait interne des champs (pour ne pas coller le texte du champ au cadre du champ).
  • les marges.
  • l'orientation de la page (portrait ou paysage).
  • le format des étiquettes si l'état est de type étiquette.
  • Versions 15 et supérieures
    le nombre de colonnes.
    Il est également possible de créer des états multicolonnes.
    Nouveauté 15
    le nombre de colonnes.
    Il est également possible de créer des états multicolonnes.
    le nombre de colonnes.
    Il est également possible de créer des états multicolonnes.
  • Versions 19 et supérieures
    le nombre de pages en largeur. Dans ce cas, un état de grande taille (supérieur à une feuille de papier) pourra s'imprimer sur plusieurs pages. L'utilisateur final devra simplement assembler les pages. Pour plus de détails, consultez Impression multipage.
    Nouveauté 19
    le nombre de pages en largeur. Dans ce cas, un état de grande taille (supérieur à une feuille de papier) pourra s'imprimer sur plusieurs pages. L'utilisateur final devra simplement assembler les pages. Pour plus de détails, consultez Impression multipage.
    le nombre de pages en largeur. Dans ce cas, un état de grande taille (supérieur à une feuille de papier) pourra s'imprimer sur plusieurs pages. L'utilisateur final devra simplement assembler les pages. Pour plus de détails, consultez Impression multipage.

Options

L'onglet "Options" de la fenêtre de description de l'état permet de configurer :
  • le fonctionnement de l'état si le format de la page n'est pas supporté par l'imprimante.
  • la position des blocs lors de l'impression de l'état.
  • le style du tableau si l'état contient un tableau.
  • la liste des modèles utilisés par l'état.
  • le style des étiquettes si l'état est de type étiquette.
Cet onglet permet également de :
  • configurer l'état pour l'utilisation du logiciel Etats et Requêtes. Pour plus de détails, consultez Logiciel Etats & Requêtes.
  • spécifier si le code compilé doit être intégré. Cette option est nécessaire dans des cas très rares.
  • configurer certains paramètres spécifiques :
    • Si chaque page doit être envoyée séparément au spooler d'impression (impression effectuée page après page). Dans ce cas, l'impression est envoyée au spooler d'impression après chaque page imprimée.
    • S'il est nécessaire de tenir compte des espaces qui complètent les rubriques. Cette option concerne uniquement les champs auto-extensibles associés à une rubrique texte complétée par des espaces (compatibilité avec WINDEV 5.5).
    • Si la première page est une page de couverture. Dans ce cas, la première page sera affichée à droite dans l'aperçu (en mode d'affichage par pages doubles).
    • Versions 22 et supérieures
      Si le code des champs clonés doit être exécuté. Par défaut, cette option est cochée. En décochant cette option, le comportement de l'état correspondra à celui des versions 21 et inférieures : le code des champs clonés ne sera pas exécuté.
      Nouveauté 22
      Si le code des champs clonés doit être exécuté. Par défaut, cette option est cochée. En décochant cette option, le comportement de l'état correspondra à celui des versions 21 et inférieures : le code des champs clonés ne sera pas exécuté.
      Si le code des champs clonés doit être exécuté. Par défaut, cette option est cochée. En décochant cette option, le comportement de l'état correspondra à celui des versions 21 et inférieures : le code des champs clonés ne sera pas exécuté.
    • Versions 23 et supérieures
      Surcharger la norme de programmation définie au niveau du projet (via le bouton "Norme de programmation"). Pour plus de détails, consultez Description du projet : Onglet Compilation.
      Nouveauté 23
      Surcharger la norme de programmation définie au niveau du projet (via le bouton "Norme de programmation"). Pour plus de détails, consultez Description du projet : Onglet Compilation.
      Surcharger la norme de programmation définie au niveau du projet (via le bouton "Norme de programmation"). Pour plus de détails, consultez Description du projet : Onglet Compilation.

Formulaire et image de fond

La majorité des types d'états peuvent être réalisés à partir d'un formulaire. L'onglet "Fond" permet de définir l'image utilisée en tant que formulaire dans l'état. Cette image pourra au choix être imprimée ou non avec l'état.
Cette option est très utile pour les états devant s'imprimer sur un formulaire pré-imprimé. L'intégration du formulaire dans l'état permet de simplifier le positionnement des champs à imprimer par rapport au formulaire. Finis les dizaines d'essais pour réaliser une impression correcte.
Pour plus de détails sur l'utilisation d'un formulaire dans un état, consultez Etat sur formulaire.

Langue

Un état peut être multilingue, c'est-à-dire qu'à l'exécution cet état pourra être affiché et imprimé dans plusieurs langues.
L'onglet "Langue" permet de configurer :
  • les différentes langues gérées par l'état en cours.
  • la langue visualisée sous l'éditeur d'états : c'est cette langue qui sera utilisée par défaut pour afficher l'état sous l'éditeur.
Les informations d'un état pouvant être saisies en plusieurs langues sont :
  • tous les messages affichés lors de l'impression de l'état. La traduction de ces messages est réalisée directement dans les différentes fenêtres de description.
  • le libellé des champs de type Libellé ou RTF : Pour traduire ces libellés, il suffit de modifier la langue affichée de l'état (option "Affichage .. Langue affichée") et de saisir directement les traductions dans l'état en édition.Pour traduire ces libellés, il suffit de :
    • modifier la langue affichée de l'état : sous le volet "Affichage", dans le groupe "Options", déroulez "Langue affichée" et sélectionnez la langue voulue.
    • saisir directement les traductions dans l'état en édition.
  • le masque d'affichage des champs de type rubrique, calculé ou prédéfini.
  • les différents fichiers image utilisés dans l'état.
  • le formulaire de l'état.
Ouvrir, fermer et enregistrer un état

Ouvrir un état

Pour ouvrir un état, il est possible d'utiliser une des méthodes suivantes :
  • sélectionner l'option "Fichier .. Ouvrir".sous le volet "Accueil", dans le groupe "Général", déroulez "Ouvrir" et sélectionnez "Ouvrir". Sélectionnez ensuite le fichier de type "WDE" à ouvrir.
  • cliquez sur Ouvrir et sélectionnez "Ouvrir". Sélectionnez ensuite le fichier de type "WDE" à ouvrir. cliquez sur Ouvrir parmi les boutons d'accès rapide et sélectionnez "Ouvrir". Sélectionnez ensuite le fichier de type "WDE" à ouvrir.
  • double-cliquez directement sur un fichier de type "WDE".
  • double-cliquez sur le nom d'un état dans le volet "Explorateur de projet".

Fermer un état

Pour fermer l'état en cours, utilisez une des méthodes suivantes :
  • cliquez sur la croix en haut à droite de la barre de titre de l'état en cours d'édition.
  • sélectionnez l'option "Fichier .. Fermer". sous le volet "Accueil", dans le groupe "Général", déroulez "Fermer" et sélectionnez "Fermer".
Si l'état contient des modifications non sauvegardées, l'éditeur d'états propose automatiquement d'enregistrer l'état.

Enregistrer un état

Pour enregistrer l'état en cours, utilisez une des méthodes suivantes :
  • sélectionnez l'option "Fichier .. Enregistrer".sous le volet "Accueil", dans le groupe "Général", cliquez sur Enregistrer.
  • utilisez le raccourci clavier Ctrl + S.
  • cliquez sur Enregistrer parmi les boutons d'accès rapide.
Remarque : L'option "Fichier .. Enregistrer sous" permet d'enregistrer l'état en le renommant.Remarque : Pour enregistrer un état en le renommant, sous le volet "Accueil", dans le groupe "Général", déroulez "Enregistrer" et sélectionnez "Enregistrer sous".

Récupération automatique

Pour éviter tout problème lors d'un blocage du système (coupure de courant par exemple), WINDEV, WEBDEV et WINDEV Mobile proposent un système de récupération automatique des éléments ouverts sous les différents éditeurs
Lorsque ce système est activé :
  • un enregistrement automatique des éléments ouverts est automatiquement effectué à une période donnée (toutes les 10 minutes par défaut).
  • lors de la ré-ouverture d'un état après un blocage système, une fenêtre de récupération automatique apparaît. Cette fenêtre propose de récupérer :
    • soit l'état tel qu'il était lors de la dernière sauvegarde réalisée depuis l'éditeur d'états.
    • soit l'état sauvegardé automatiquement.
      La version sélectionnée est automatiquement ouverte sous l'éditeur d'états. La version non sélectionnée est disponible dans la fenêtre de gestion des versions et peut être ouverte à tout moment. Pour plus de détails sur la gestion des versions, consultez la gestion des versions.
Pour activer le système de récupération automatique :
  1. Sélectionnez l'option "Outils .. Options .. Options générales de xxx".Sous le volet "Accueil", dans le groupe "Environnement", déroulez "Options" et sélectionnez "Options générales de xxx".
  2. Affichez l'onglet "Général" et cochez l'option "Enregistrement pour la récupération automatique".
  3. Précisez le délai de l'enregistrement automatique.
  4. Validez.
Pour récupérer une version dans la fenêtre de gestion des versions :
  1. Sélectionnez l'option "Fichier .. Versions".Sous le volet "Accueil", dans le groupe "Général", déroulez "Enregistrer" et sélectionnez "Versions".
  2. Sélectionnez la version à récupérer.
  3. Validez.
Voir Aussi
Version minimum requise
  • Version 10
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire