PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Nouveauté WINDEV 24 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
<Variable Certificat>.OuvrePropriétés (Fonction)
En anglais : <Certificate variable>.OpenProperties
Ouvre la fenêtre Windows permettant de connaître les propriétés d’un certificat. Cette fenêtre est la suivante :
Exemple
MonCertificat est un Certificat

// Ouverture du sélecteur de certificat de Windows
MonCertificat = CertificatSélecteur()

// Annulation ou erreur
SI MonCertificat..Nom = "" ALORS
RETOUR
FIN

// Teste si le certificat sélectionné est valide pour signer
SI MonCertificat..ValidePourSignature = Faux ALORS
Info("Le certificat sélectionné ne permet de pas de générer une signature.")
RETOUR
FIN

// Récupération du buffer contenant la signature
bufSignature est un Buffer
bufSignature = CertificatSigneChaîne("Chaîne de caractères à signer", MonCertificat)

// Récupération du certificat contenu dans le buffer de la signature
MonCertificatExtrait est un Certificat
MonCertificatExtrait = CertificatExtrait(bufSignature)

// Gestion des erreurs
SI MonCertificatExtrait = Null ALORS
RETOUR
FIN

// Ouverture de la fenêtre des propriétés du certificat
MonCertificatExtrait.OuvrePropriétés()
Syntaxe
<Résultat> = <Certificat>.OuvrePropriétés()
<Résultat> : Booléen
  • Vrai si la fenêtre des propriétés du certificat a été ouverte,
  • Faux dans le cas contraire.
<Certificat> : Variable de type Certificat
Nom de la variable de type Certificat contenant le certificat dont les propriétés doivent être affichées.
Composante : wd240std.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire