PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Nouveauté WINDEV 24 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Récupère la position d'attache d'un champ Panneau dockable.
Exemple
// Récupère la position du Champ Panneau dockable "PADO_TEST"
SELON PanneauPosition(PADO_TEST)
CAS padoGauche
// Le champ Panneau dockable est attaché à gauche.
CAS padoDroite
// Le champ Panneau dockable est attaché à droite.
CAS padoHaut
// Le champ Panneau dockable est attaché en haut.
CAS padoBas
// Le champ Panneau dockable est attaché en bas.
CAS padoFlottant
// Le champ Panneau dockable est flottant.
FIN
// Si le panneau est à gauche, le mettre à droite
SI PanneauPosition(PADO_Test) = padoGauche ALORS
PanneauAttache(PADO_Test, padoDroite)
FIN

// Crée un configuration avec 2 panneaux en bas dans la même zone
PanneauAttache(PADO_Détail, padoBas)
PanneauAttache(PADO_Infos, PanneauPosition(PADO_Détail))
Syntaxe
<Résultat> = PanneauPosition(<Panneau>)
<Résultat> : Chaîne de caractères ou constante
  • Chaîne vide ("") si le champ Panneau dockable est un panneau flottant.
  • Position du champ Panneau dockable. Peut correspondre à une des constantes suivantes ou à une combinaison des constantes suivantes :
    padoBasLe champ Panneau dockable est attaché en bas
    padoDroiteLe champ Panneau dockable est attaché à droite.
    padoFlottantLe champ Panneau dockable est flottant.
    Cette constante est disponible uniquement à partir de WINDEV 24 Update 1.
    padoGaucheLe champ Panneau dockable est attaché à gauche.
    padoHautLe champ Panneau dockable est attaché en haut.

Les constantes sont combinables.
<Panneau> : Nom de champ
Nom du champ Panneau dockable à manipuler.
Remarques
  • La position peut être modifiée avec la fonction PanneauAttache.
  • Si le champ Panneau dockable est flottant, sa position peut être connue via les propriétés ..X et ..Y.
Composante : wd240obj.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire