PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV, WINDEV Mobile 24 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Récupère l'identité d’un utilisateur contenue dans une variable de type AuthToken.
Remarque : Cette fonction peut être utilisée dans le cas d'une authentification utilisant le protocole OAuth 2.0 sur un Webservice quelconque.
Exemple
OpenIDParams est un OpenIDParamètres
OpenIDParams..URLConfiguration = "https://accounts.google.com/.well-known/openid-configuration"
OpenIDParams..ClientID = "106034950318?????????k59q.apps.googleusercontent.com"
OpenIDParams..ClientSecret = "oBTQL52J??????-76MpiM"
OpenIDParams..URLRedirection = "http://localhost:9846"

MonToken est un AuthToken = AuthIdentifie(OpenIDParams)
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN

MonIdentité est un OpenIDIdentité = MonToken.OpenIDLitIdentité()
SI MonIdentité..Valide ALORS
Trace(MonIdentité..Email)
Trace(MonIdentité..Nom)
Trace(MonIdentité..Prénom)
FIN
Syntaxe
<Résultat> = <Token d'authentification>.OpenIDLitIdentité()
<Résultat> : Variable de type OpenIDIdentité
Variable de type OpenIDIdentité contenant les informations de l'utilisateur authentifié.
<Token d'authentification> : Variable de type AuthToken
Nom de la variable de type AuthToken correspondant au token (ou jeton) contenant les informations d'accès pour les prochaines requêtes authentifiées.
Composante : wd240ggl.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire