PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

  • Propriétés spécifiques à la description des variables de type OpenIDIdentité
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget iOSApple WatchCatalystUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Le type OpenIDIdentité permet de définir toutes les caractéristiques avancées d'un utilisateur connecté à un service via le protocole OAuth 2.0. Les caractéristiques de cet utilisateur peuvent être définies et modifiées à l'aide de différentes propriétés WLangage.
Remarque : Pour plus de détails sur la déclaration de ce type de variable et l'utilisation des propriétés WLangage, consultez Déclaration d'une variable.
Exemple
OpenIDParams est un OpenIDParamètres
OpenIDParams..URLConfiguration = "https://accounts.google.com/.well-known/openid-configuration"
OpenIDParams..ClientID = "1060349503186-pc7ahme???????7gk59q.apps.googleusercontent.com"
OpenIDParams..ClientSecret = "oBTQL52?????y9-76MpiM"
OpenIDParams..URLRedirection = "http://localhost:9846"

MonToken est un AuthToken = AuthIdentifie(OpenIDParams)
SI ErreurDétectée ALORS
Erreur(ErreurInfo())
RETOUR
FIN

MonIdentité est un OpenIDIdentité = OpenIDLitIdentité(MonToken)
SI MonIdentité..Valide ALORS
Trace(MonIdentité..Email)
Trace(MonIdentité..Nom)
Trace(MonIdentité..Prénom)
FIN
Remarques

Propriétés spécifiques à la description des variables de type OpenIDIdentité

Les propriétés suivantes peuvent être utilisées pour manipuler un utilisateur :
Nom de la propriétéType manipuléEffet
EmailChaîne de caractèresAdresse email de l’utilisateur.
Attention : Selon le provider utilisé, cette information peut être vide.
IDTokenBufferToken OpenID.
NomChaîne de caractèresNom de l’utilisateur.
Attention : Selon le provider utilisé, cette information peut être vide.
PrénomChaîne de caractèresPrénom de l’utilisateur.
Attention : Selon le provider utilisé, cette information peut être vide.
SourceJSONPropriétés de l'utilisateur.
ValideBooléen
  • Vrai si l’identité est valide,
  • Faux dans le cas contraire.

Remarque : Ces propriétés peuvent être utilisées en utilisant une des deux syntaxes suivantes :
  • <Nom de la variable>..<Nom de la propriété>
  • <Nom de la variable>.<Nom de la propriété>
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire