PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Récupère la liste des fichiers MongoDB présents dans le système de fichiers MongoDB (gridFS).
Versions 24 et supérieures
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Nouveauté 24
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WINDEVLinux Cette fonction est désormais disponible pour les applications WINDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Exemple
tabListeFichier est un tableau de mongoGridFSInfoFichier

tabListeFichier = MongoGridFSListeFichier(CnxMDB..BaseDeDonnées["CRM"])
POUR TOUT Fic DE tabListeFichier
// Traite le fichier
Trace(Fic..Nom)
FIN
TableSupprimeTout(TABLE_GridFS)

tabFichier est un tableau de mongoGridFSInfoFichier = MongoGridFSListeFichier(gclGridFS)
fic est un mongoGridFSInfoFichier
POUR TOUT fic DE tabFichier
TableAjouteLigne(TABLE_GridFS, VariantVersJSON(fic..ID), ...
fic..Nom, fic..Date, fic..Md5, fic..Taille, fic..TailleChunk, fic..TypeContenu)
FIN

TableSelectMoins(TABLE_GridFS)
Syntaxe
<Résultat> = MongoGridFSListeFichier(<Système de fichiers>)
<Résultat> : Tableau de mongoGridFSInfoFichier
Tableau de variables de type mongoGridFSInfoFichier, correspondant à la description des fichiers listés.
<Système de fichiers> : Variable de type mongoGridFS ou de type mongoBase
Système de fichiers de la base MongoDB à manipuler. Correspond :
  • au nom de la variable de type mongoGridFS correspondant au système de fichiers Mongo.
  • au nom de la variable de type mongoBase correspondant à la base MongoDB. Dans ce cas, le système de fichiers utilise le préfixe "fs".
Liste des exemples associés :
Accès natif à MongoDB Exemples unitaires (WINDEV) : Accès natif à MongoDB
[ + ] Cet exemple présente l'utilisation des principales fonctions de l'accès natif aux bases MongoDB : ajout de données, lecture (recherche), modification et suppression de données dans la base. L'exemple présente également les fonctions permettant d'enregistrer des fichiers dans le système de données de MongoDB GridFS.
Composante : wd240big.dll
Version minimum requise
  • Version 22
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire