PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEVWEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadWidget IOSApple WatchMac CatalystUniversal Windows 10 App
Autres
Procédures stockées
Envoie des données d'un téléphone iOS vers une montre Apple Watch (ou inversement) en demandant une réponse.
Exemple
PROCÉDURE INTERNE RéceptionInfo(b est Buffer)
Info(b)
FIN
 
MonBuffer est un Buffer = "Buffer Texte"
SI PAS awEnvoieEtRécupèreInfo(MonBuffer, RéceptionInfo) ALORS
Erreur(ErreurInfo())
FIN
Syntaxe
<Résultat> = awEnvoieEtRécupèreInfo(<Données> , <Procédure WLangage>)
<Résultat> : Booléen
  • Vrai si l'envoi a réussi,
  • Faux dans le cas contraire. La fonction ErreurInfo permet d'obtenir plus de détails sur l'erreur.
<Données> : Buffer
Données à envoyer.
<Procédure WLangage> : Nom de procédure
Nom de la procédure WLangage (également nommée "callback") appelée lors de la réception de la réponse. Cette procédure permet de récupérer et traiter la réponse reçue.
Cette procédure est de la forme :
PROCEDURE <Nom de la procédure>(<Réponse>)

où <Réponse> est une variable de type Buffer.
Remarques
  • Le récepteur obtient les données envoyées par l'intermédiaire de la procédure passée à la fonction awProcédureRéceptionEtEnvoiInfo. Le récepteur doit alors envoyer une réponse en valeur de retour de cette procédure.
  • Les données sont envoyées immédiatement.
    • Dans le sens "Montre vers Téléphone" : si l'application iOS n'est pas démarrée, elle sera démarrée automatiquement en arrière-plan pour pouvoir répondre à l'appel.
    • Dans le sens "Téléphone vers Montre" : si l'application Apple Watch n'est pas démarrée, l'appel génère une erreur.
  • Les messages sont délivrés dans l'ordre où ils ont été envoyés.
Version minimum requise
  • Version 21
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire