PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

Nouveauté WINDEV, WEBDEV, WINDEV Mobile 24 !
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Effectue une requête de communication (requête HTTP) à la Graph API de Facebook.
Versions 22 et supérieures
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
Nouveauté 22
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
Exemple
Cnx_FACEBOOK est un fbSession
FBRésultatRequête est un Variant
sJSON est un Buffer

Cnx_FACEBOOK..AppID = "FACEBOOK_APP_ID"
Cnx_FACEBOOK..AppSecret = "FACEBOOK_APP_SECRET"
Cnx_FACEBOOK..Permission = [fbInfoProfil]

SI Cnx_FACEBOOK.Ouvre() ALORS

// Interrogation de Facebook pour récupérer l'utilisateur
// (équivalent de FBRécupèreInformationUtilisateur)
sJSON = Cnx_FACEBOOK.Requête("https://graph.facebook.com/me?fields=id,name")

SI sJSON <> "" ALORS
FBRésultatRequête = sJSON.VersVariant()
Info(FBRésultatRequête.id, FBRésultatRequête.name)
SINON
Erreur(ErreurInfo())
FIN

// Interrogation de Facebook pour récupérer des notifications
sJSON = Cnx_FACEBOOK.Requête("https://graph.facebook.com/me/notifications?limit=0")

SI sJSON <> "" ALORS
FBRésultatRequête = JSONVersVariant(sJSON)
Info(FBRésultatRequête.summary.unseen_count, FBRésultatRequête.summary.updated_time)
SINON
Erreur(ErreurInfo())
FIN
SINON
Erreur("Impossible de se connecter.", ErreurInfo())
FIN
Syntaxe
<Résultat> = <Session>.Requête(<Requête> [, <Type> [, <Données>]])
<Résultat> : Buffer
Résultat de la requête.
<Session> : Variable de type fbSession
Nom de la variable de type fbSession correspondant à la connexion Facebook à manipuler.
<Requête> : Chaîne de caractères (avec guillemets)
URL complète de la requête (avec si nécessaire les paramètres stockés dans l'URL).
<Type> : Constante optionnelle de type Entier
Type de la requête HTTP à envoyer :
httpDeleteMéthode DELETE.
httpGet
(valeur par défaut)
Méthode GET.
httpPostMéthode POST.
httpPutMéthode PUT.
<Données> : Buffer optionnel
Données à envoyer sur le serveur (uniquement dans le cas d'une requête POST ou PUT).
Composante : wd240ggl.dll
Version minimum requise
  • Version 24
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire