PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Liste les variables présentes dans la session MATLAB.
Versions 24 et supérieures
WindowsAjax Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
Nouveauté 24
WindowsAjax Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
WindowsAjax Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
Exemple
gnIdSession est un entier
gnIdSession = mlInitialise()

SI gnIdSession = -1 ALORS
Erreur(ErreurInfo(errComplet))
FIN

// Code du bouton BTN_ListeVariable
sListeVar est une chaîne = mlListeVariable(gnIdSession)

SAI_Résultat = sListeVar
gnIdSession est un entier
gnIdSession = mlInitialise()

SI gnIdSession = -1 ALORS
Erreur(ErreurInfo(errComplet))
FIN

// Code du bouton BTN_Creation_Variables
tParamètre est un tableau de 1 réel = [4]
tRésultat est un tableau  de 1 par 1 réel = [[123]]

SI PAS mlEcritVariable(gnIdSession, "i", tParamètre) ALORS
Erreur("Echec d'écriture de la variable")
RETOUR
FIN

sCodeAExécuter est une chaîne = "maRac = sqrt(i)"
SAI_Résultat = mlExécute(gnIdSession, sCodeAExécuter)

tRésultat = mlRécupèreVariable(gnIdSession, "maRac")
SI ErreurDétectée ALORS
Trace("Erreur : " + ErreurInfo())
FIN

Trace("Racine = " + tRésultat[1,1])

Trace("Liste des variables avant suppression : " + mlListeVariable(gnIdSession))

mlSupprimeVariable(gnIdSession, "i")
mlSupprimeVariable(gnIdSession, "maRac")

Trace("Liste des variables après suppression : " + mlListeVariable(gnIdSession))
Syntaxe
<Résultat> = mlListeVariable(<Identifiant de la session>)
<Résultat> : Chaîne de caractères
Liste des variables présentes dans la session MATLAB. Les variables sont séparées par un Retour-Chariot (RC).
<Identifiant de la session> : Entier
Identifiant de la session MATLAB. Cet identifiant est renvoyé par la fonction mlInitialise.
Composante : wd240com.dll
Version minimum requise
  • Version 20
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire