PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

  • Types supportés
WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Ecrit la valeur d’une variable de la session MATLAB.
Versions 24 et supérieures
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
Nouveauté 24
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
WEBDEV - Code ServeurWindows Cette fonction est désormais disponible pour les sites WEBDEV sous Windows.
Exemple
gnIdSession est un entier
gnIdSession = mlInitialise()

SI gnIdSession = -1 ALORS
Erreur(ErreurInfo(errComplet))
FIN

// Code du bouton BTN_Creation_Variables
tParamètre est un tableau de 1 réel = [4]
tRésultat est un tableau  de 1 par 1 réel = [[123]]

SI PAS mlEcritVariable(gnIdSession, "i", tParamètre) ALORS
Erreur("Echec d'écriture de la variable")
RETOUR
FIN

sCodeAExécuter est une chaîne = "maRac = sqrt(i)"
SAI_Résultat = mlExécute(gnIdSession, sCodeAExécuter)

tRésultat = mlRécupèreVariable(gnIdSession, "maRac")
SI ErreurDétectée ALORS
Trace("Erreur : " + ErreurInfo())
FIN

Trace("Racine = " + tRésultat[1,1])

Trace("Liste des variables avant suppression : " + mlListeVariable(gnIdSession))

mlSupprimeVariable(gnIdSession, "i")
mlSupprimeVariable(gnIdSession, "maRac")

Trace("Liste des variables après suppression : " + mlListeVariable(gnIdSession))
Syntaxe
<Résultat> = mlEcritVariable(<Identifiant de la session> , <Nom de la variable> , <Valeur>)
<Résultat> : Booléen
  • Vrai si la variable a été modifiée,
  • Faux dans le cas contraire. En cas d'erreur, la variable ErreurDétectée est à Vrai. Pour connaître le libellé de l'erreur, utilisez la fonction ErreurInfo avec la constante errMessage.
<Identifiant de la session> : Entier
Identifiant de la session MATLAB. Cet identifiant est renvoyé par la fonction mlInitialise.
<Nom de la variable> : Chaîne de caractères (avec guillemets)
Nom de la variable à écrire.
<Valeur> : Tableau d'entiers, de réels, ...
Valeur de la variable.
Remarques

Types supportés

Les types supportés sont :
  • entiers signés et non signés sur 1, 2, 4 et 8,
  • réels sur 4 et 8,
  • booléens,
  • caractères.
Composante : wd240com.dll
Version minimum requise
  • Version 20
Documentation également disponible pour…
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire