PC SOFT

DOCUMENTATION EN LIGNE
DE WINDEV, WEBDEV ET WINDEV MOBILE

WINDEV
WindowsLinuxUniversal Windows 10 AppJavaEtats et RequêtesCode Utilisateur (MCU)
WEBDEV
WindowsLinuxPHPWEBDEV - Code Navigateur
WINDEV Mobile
AndroidWidget AndroidiPhone/iPadApple WatchUniversal Windows 10 AppWindows Mobile
Autres
Procédures stockées
Valide la création d'un nouvel utilisateur dans la base de données du groupware utilisateur en activant l'utilisateur.
Selon le mode de validation des nouveaux utilisateurs paramétré dans la page d’administration, il est possible :
  • soit d'envoyer un email à l’utilisateur pour lui demander de cliquer sur un lien qui validera son inscription,
  • soit de valider l’utilisateur directement.
Versions 24 et supérieures
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Nouveauté 24
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
WEBDEV - Code ServeurLinux Cette fonction est désormais disponible pour les sites WEBDEV sous Linux.
Exemple
// Valeurs du nouvel utilisateur
clUtilisateur est un gpwUtilisateur
clUtilisateur..Email = SAI_Email
clUtilisateur..Login = SAI_Login
clUtilisateur..MotDePasse = SAI_MotPasse
clUtilisateur..Nom = SAI_Nom
clUtilisateur..Prénom = SAI_Prenom
clUtilisateur..Téléphone = SAI_Telephone

// Ajout de l'utilisateur
SI gpwAjouteUtilisateur(clUtilisateur) = Faux ALORS
Info("Impossible d'ajouter l'utilisateur.")
RETOUR
FIN

// Activation de l'utilisateur
SELON gpwActiveUtilisateur(clUtilisateur..Login)
// Pour une activation par email
CAS gpwActivationParEmail
PopupAffiche(POPUP_ValidationInscription)

// Pour une activation immédiate
CAS gpwActivationImmédiate
// Connecte directement l'utilisateur
gpwConnecteUtilisateur(clUtilisateur..Login, clUtilisateur..MotDePasse)
// Affiche la popup de confirmation
PopupAffiche(POPUP_ConfirmationInscription)

AUTRE CAS
Info("Impossible d'activer l'utilisateur.")
FIN
Syntaxe
<Résultat> = gpwActiveUtilisateur(<Identifiant>)
<Résultat> : Constante de type Entier
Résultat de l'activation :
gpwActivationImmédiateL'utilisateur est immédiatement activé.
gpwActivationParEmailL'utilisateur est activé par email. Un email lui est automatiquement envoyé (les caractéristiques de l'email ont été définies dans la page d’administration).
gpwErreurErreur d'activation.
<Identifiant> : Chaîne de caractères (avec guillemets)
Login ou email de l'utilisateur.
Remarques
En cas d’erreur, la variable ErreurDétectée est à Vrai.
Composante : wd240gpu.dll
Version minimum requise
  • Version 19
Commentaires
Cliquez sur [Ajouter] pour publier un commentaire